Printer Sharing (connected to Win XP) - where 2 get the PDD file?

Discussion in 'macOS' started by striders, Mar 11, 2009.

  1. striders macrumors 6502

    Joined:
    Mar 11, 2009
    #1
    Hi all,

    I have a quite recent printer, a Canon iP90 portable printer that have both WinXP and OSX drivers.

    I have installed the OSX drivers (.pkg files) on my late 2008 MacBook Pro (MBP) and the printer works just fine. Canon even install its own application to monitor inks, etc.

    I now connect the printer to a Windows XP and share the printer. All the other Windows laptop can use the printer.

    I tried to connect to the printer (now shared via Windows XP) from my OSX. (Instructions from http://guides.macrumors.com/Printing...red_PC_Printer)

    I assume the driver is already in my MBP because I installed earlier. However, when CUPS asked for the drivers, it did NOT list the printer (Canon IP90). It then ask me to provide the PDD file. I can't find this at all.

    So what do I need to do?
    __________________
     
  2. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #3
    Yes, I did. As mentioned in my 1st post, I have installed the Canon iP90 drivers and utility on the OSX when I connect the printer directly to the MBP.

    Thus, I assume the drivers is already installed in my MBP.

    However, the CUPS app didn't list the iP90. It also ask for the "PDD" file.

    I opened the .dmg file and click the .pkg file (there is only one) then click "Show Package Contents" to search the file (keyword: drivers, pdd, etc).

    I even went to Macintosh HDD -> Library -> Printers -> Canon and look there but to no avail.
     
  3. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #4
    Okay, from what I understand, there are two types of drivers, and for local printers, it does not use the CUPS driver.

    The newer Canon printers are not supported by the Gimp-Print drivers included with 10.5. I found a reference to www.printfab.net which may have the driver for your printer included.

    I would try there first.
     
  4. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #5
    Thanks, Belvdr. I downloaded the trial and tried again to connect via 2 methods:

    1) CUPS via browser
    2) Printers via System Preferences (I added the "Advanced" toolbar button per Apple support page to show "Windows" in the drop-down box)

    Neither can see the IP90 driver for some reason. I'll try do some digging to verify.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    You will find that all of these are known issues with the Canon iP90.
     
  6. striders thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #7
    Shot, that's not good. That means I have to buy a new printer but this time with WiFi built-in. I think the Epson Artisan 800 is a good choice.
     

Share This Page