Printer woes...

Discussion in 'Mac Accessories' started by BentwoodBlue, Nov 4, 2007.

  1. BentwoodBlue macrumors member

    Joined:
    Aug 6, 2007
    #1
    Hooray! MBP day has finally arrived. This is my first Mac so there is a small learning curve, but nothing too difficult.

    I am having issues installing my printers.
    I am running Leopard.
    #1
    I am trying to install a networked LaserJet 2100 (Uses JetDirect 170x). The installation seemed like a piece of cake, but when I print a test page I get 2 pages of garbage and 10-15 blank pages.

    #2
    A much smaller priority..
    I have a Canon PIXMA MP470. I installed it on my son's windows desktop. I have managed to connect to the printer, but even though I have installed the drivers on my Mac I cannot find the proper driver for it.

    Any ideas are certainly most welcome!
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    For the 2100 - you have tried using the 2100M or 2100 series postscript driver to a non-postscript printer. Use the Laserjet 2100 Gutenprint driver.

    For the Canon - There is a major issue that Apple still hasn't addressed in Leopard - having two ways to program print drivers - Carbon and CUPS. Carbon drivers (used by most non-postscript printer manufacturers) bypass CUPS - but CUPS is what provides the standard network protocols. You need a CUPS driver, not the Canon-provided Carbon driver. Try the Gutenprint MP500 or MP700 driver to see if it works.
     
  3. BentwoodBlue thread starter macrumors member

    Joined:
    Aug 6, 2007
    #3
    Really appreciate the response.

    I will try printing to the 2100 when I get home from class today.

    As far as the Canon goes, I did try the MP500 driver and I got an error.. I will try the 700 as well.
    Thanks!
     
  4. Aninka macrumors newbie

    Joined:
    May 27, 2008
    #4
    Canon MP700 - extreme trouble

    Hello to one and all,

    I am encountering extreme difficulties with my Canon MP700 printer.

    I have a MacBook that was just recently upgraded to Leopard. Before this upgrade, I was able to print directly from my MacBook to the MP700 via a USB cable. After the upgrade, my computer is able to find the printer and recognizes that it is in fact MP700 (using the same USB cable as before), but I cannot for the life of me print anything out. After spending numerous hours researching various forums and trying different drivers, I am still without a functioning printer connection. Any suggestions? I tried a few of the different Canon drivers that are not quite MP700 but sound a lot like they could pass as a functioning substitute - no luck there.

    With gratitude - Anna
     
  5. BallyT macrumors newbie

    Joined:
    Jul 7, 2008
    #5
    I'm using MP700 - colours all wrong

    Hey all, I'm using the MP700 as picked by the mac and it is only now dawning on me. My colours are all messed up. WHilst Black is black, red is coming out yellow and blue - white. So the driver is not working for me at all really. Anyone who has answer would be fantastic.
     

Share This Page