Printing crashes in Admin account but not other accounts

Discussion in 'Mac OS X Lion (10.7)' started by SamPhoto, Sep 21, 2011.

  1. SamPhoto macrumors member

    Joined:
    Nov 30, 2007
    #1
    I've been plagued with a problem that I can't seem to resolve. Printing from Safari, Chrome, or Firefox instantly crashes that app when trying to print using the Admin account. I can login to a Guest account and can print just fine. I've done the usual repair of permissions, latest driver, removed and reinstalled printer, etc, but nothing seems to work. Is there a way to compare two accounts and in order to see find the difference that's causing the problem? Any help or suggestions will be greatly appreciated. Thanks!
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    Try resetting the printing system. In Print & Scan in System Preferences, right-click on an empty section of the Printer List, and select the "Reset printing system…" option that pops up, then add the printer again.

    jW
     
  3. SamPhoto thread starter macrumors member

    Joined:
    Nov 30, 2007
    #3
    Thanks JW, but I already did that a few times with no luck :(
     
  4. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #4
    Ok, you didn't mention it, so I wanted to make sure.

    Next thing to check is preferences. Go to ~/Library for the non-working account, take everything in it and drag them to a new folder somewhere else. Try printing something. If it works, put half of the preference files back in. If it still works, then try putting the other half back too. If it stops working at any point, you've got your culprit narrowed down. If it never starts working, then it's not the preferences, but they're a common culprit for issues like this. You can repeat the process with smaller groups until you find the problem file.

    jW
     

Share This Page