Printing in 10.6.8

Discussion in 'Design and Graphics' started by dazzer21, Jun 6, 2012.

  1. dazzer21, Jun 6, 2012
    Last edited by a moderator: Jun 7, 2012

    dazzer21 macrumors 6502

    Oct 18, 2005
    Until recently I was using an iMac 8,1 running 10.5.8. One hard drive and disk controller failure later, the machine's toast. So now I have a newer, pre-owned version, which arrived running 10.6.8 - only thing missing from it was an OS disk but it did come with an external HD mirroring the internal one so I have a backup should I require it. The only problem I didn't see coming is that it's killed my printer. I've re-installed my printer drivers and the thing won't print. It just says that the print queue has been paused and it won't start up again. I bought my home iMac into the office (which is running 10.5.8) and that works fine, so it's not a hardware issue as far as the printer is concerned.

    However, I have a had a little delve using the Google and it transpires that this is a major issue which affects 10.6.8 as a whole. I've trawled the forums, including Apple support, and all the workarounds I've managed to find have not worked. I've looked at Ricoh's website and downloaded the latest driver, have consulted Fiery and loaded up the latest version of their drivers and I still can't get it to work. A couple of forums suggest manipulating the code in the PPD file and I've also tried that to no avail.

    Some people have claimed success with their repairs, but the common theme appears to be the downgrade to at least 10.6.7 (which requires an initialise/install which makes my teeth go on edge at the mere thought of it!). Also, 10.6.8 is the only version of the OS I hold, so I'm double stuffed.

    Any ideas? This is ridiculous... :confused: :mad:
  2. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
  3. dazzer21 thread starter macrumors 6502

    Oct 18, 2005
    The printer is a Ricoh Aficio 4506, which although it's as old as the hills, is still serving us very well. I've been using a Fiery E-310 Colour Controller for the RIP. However, that has been deemed unusable by the system (too old, I guess) and now I'm using an RC-210 driver from Ricoh.

Share This Page