Printing problem with Fusion

Discussion in 'Windows, Linux & Others on the Mac' started by ktbills, Jan 21, 2008.

  1. ktbills macrumors newbie

    Joined:
    Jan 9, 2008
    #1
    I have a new MacBook running Leopard, with a boot camp partition with XP installed. From both OS X and XP, I print to an old HP 932c deskjet that refuses to die. Windows has apparently installed its own drivers because in the Printers control panel, the HP printer is listed twice (but only one works). The printer is networked using a D-link device (I forget what it is exactly) that allows the printer to connected directly to a router.

    When I launch Fusion and try to print, I get an error message that Windows cannot print due to a problem with the current printer setup and suggesting I reinstall the drivers. If I go to the Menu bar in Fusion and select Printers, I see the same printers I see in XP and the same one is selected as the default printer as is selected in boot camp. If I right-click on that printer to check properties, it tells me that "Printer properties cannot be displayed. The print spooler service is not running."

    Any suggestions would be greatly appreciated. Thanks.

    Ken
     
  2. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
    #2
    can you print from your xp bootcamp partition?
    edit:scrub that just read the post again
     
  3. ktbills thread starter macrumors newbie

    Joined:
    Jan 9, 2008
    #3
    Yes. Printing from Bootcamp (when not using Fusion) works just fine.
     
  4. neilhart macrumors 6502

    neilhart

    Joined:
    Oct 11, 2007
    Location:
    SF Bay Area - Fremont
    #4
    Printing from VMware Fusion BootCamp XP

    I just went through this. In my case, I found that running Virtual BootCamp XP I did not see my Windows shares and could not print as you indicate.

    I opened a cmd window and ran "ipconfig" and saw the sub-net ip address of 172... something (my local sub-net is 192.168.0.n).

    That was the problem.

    Went to VMware, Virtual Machine pull down, to Network and changed from NAT to Bridged.

    Closed the menus, closed Window Explorer. Opened a cmd window, ran "ipconfig /release" followed by "ipconfig /renew" and was pleased to see a 192... ip address was now assigned.

    Reopened Window Explorer and there were my Window shares. And printing worked (because now everything is on the same sub-net).

    I love it. OSX Spaces: One Space has VMware Fusion Windows XP full window with all of the MS Office applications fully functional, etc. And all the other Spaces with my Apple apps.



    Hope this helps.
    Neil.
     
  5. ktbills thread starter macrumors newbie

    Joined:
    Jan 9, 2008
    #5
    VMWare's suggested fix

    Thanks, Neil. In my case, the shared Windows printer shows up in the printers control panel, but apparently the virtual machine can't communicate with it. Still it sounds as if you and I had the same problem. I take it that your fix did not otherwise affect your virtual machine's ability to communicate with other computers on your local network, because I think that works fine though maybe I will double check.

    Since I was still in the first 30 days of owning Fusion and entitled to 30 days of email support I had also posted the same query to VMware. Just in case anyone else is interested I am posting their suggestions. They provided a couple of alternative ways, one of which I think is probably using the Mac printer driver and the other using the Windows printer driver.

    I will not have a chance to try anything for a few days. I think I will try your method first -- I would prefer to use the Windows printer driver if possible because the printer, for whatever reason, has never responded as well to the Mac driver. In the meantime, any further thoughts would be welcome.

    I will post again to report on what I did and how it worked.

    Here is the VMWare Tech Support suggestion to fix my issue:

    "We are suggesting you to delete the existing printer in the control panel of
    the guest OS and reconfigure the printer.

    "Please go through the below steps to configure the printer in Virtual
    Machine.

    A. Steps to configure the Virtual Machine to "NAT" network mode.

    a) Go to VMware Fusion settings

    b) Click on "Network"

    c) Enable "NAT" Mode

    d) Click on "OK"

    e) Reboot the VM (Don't suspend)

    B. Steps to configure the Printer.

    1. Share the printer in Host Mac OS X by going to System Preference >
    Sharing

    2. Select the printer to Share the printer (ensure that you are able to
    print in Host Mac OS)

    3. Also enable (Windows Sharing) SMB sharing in System Preferences

    a. Click on System Preference > Sharing

    b. Click on the "File Sharing" and then click on "Options"

    c. Enable "Share files and folder using SMB" and select your "User
    Name"

    d. Check mark on the "User Name" and click on "Done"

    4. Launch VMware Fusion and Power on Windows VM

    5. In Windows Guest OS, Click Windows Start > Run

    6. Key In \\IPaddress of Host Mac (for e.g. \\10.0.0.17)

    7. Now you can access your Host shared printer in Windows OS

    8. Right click on printer and select open/Connect

    9. It will ask you to install printer drivers

    10. Install Latest Printer driver available for Windows OS and check if
    you can print from Windows Virtual Machine

    "If the problem still persists, please go through the below steps.

    A. Please go through the below steps to configure the network

    a) Go to Fusion setting

    b) Go to "Network"

    c) Enable "Bridge" Mode

    d) Click on "OK"

    e) Reboot the VM (Don't suspend)

    B. Go through the below steps to configure the network printer

    a) Go to guest OS and click on "Start"

    b) Then click on "Settings" and then "Printers and faxes"

    c) Click on "File" and select "Add Printer"

    d) Follow the Printer Wizard

    e) Click on "A network printer" and then "Next"

    f) Click "Connect to this (or to browse for printer, select this option
    and click next) the first option.

    g) Key in the IP address of the printer followed by "\\"


    h) Click on "Next"

    i) Install the latest printer driver

    j) Now test the printer by printing the documents"
     
  6. ktbills thread starter macrumors newbie

    Joined:
    Jan 9, 2008
    #6
    Problem solved

    Neil, I tried your suggestion first. When I checked my ipconfig I was in bridged mode with an address of 192.168.206.__ when everything else is in 192.168.0.__ on my local network. I switched to Bridged mode, as you suggested, then released and renewed my ipconfig, and was assigned a 192.168.0.__ address for the virtual machine. Unfortunately I still couldn't print. Same error message as before.

    So then I tried the VMWare tech support method number 1 above using NAT mode. Following their instructions I got to the point where it asked me to install printer drivers which I did, but the end result was that I still couldn't print.

    Finally I tried the VMWare tech support method number 2 above using bridged network mode, which I like better because under bridged network mode I get an IP address that matches my other home computers so I can access shared files, which I never managed to do in NAT mode. Their suggestion that I type in the ip address of the printer did not work, I got an error message each time. But using the browse option, after many unsuccessful attempts I was finally able to (1) figure out in which of the network areas the on-line printer was and (2) by double-clicking on the right area get that printer to show up as choice I could click on. When I did, it asked me if I wanted to install printer drivers, which I did. And when it was done the printer worked.

    So thanks for your help. Your suggestion did not cure my problem but helped me to understand the VMWare tech support instructions.

    P.S. I agree with you about spaces. I also see from your other posts that you tend to keep Windows open your Mac all the time. Do you use a firewall or antivirus in your VM, and if so, what do you use?
     
  7. ruious macrumors newbie

    Joined:
    Jun 19, 2008
    #7
    still unable to print

    All, I've followed all the instructions below and still am unable to print.

    I can get the printer set up in Windows, however when I open the printer window up, in the windows title bar, I see the printer name and "access denied, unable to connect."

    Very frustrated. Ready to take my brand new mac and vm fusionware and throw it out the window.

    Can someone please help?
     
  8. fusionUser macrumors newbie

    Joined:
    Apr 4, 2009
    #8
    I also got somewhere via some of the above suggestions, but in Fusion 2.0.3 it actually appears to be much simpler. With or without printer sharing or file sharing on the Mac side, it seems all you really need to do to access a networked printer is to Shut Down windows with VMware Fusion open, then naviagate to "Window" in the main VMware Fusion menu bar above, then pull down to "Virtual Machine Library." A window will pop-up. Click on the "settings" button on the bottom then click on printer settings. Finally, click on the button to Fusion to find the Mac printers. Then run Windows. Next time you try to print, you'll see all the printers that you normally see in MacOS.

     
  9. Yaminom macrumors newbie

    Joined:
    Apr 6, 2009
    #9
    Simple alternative

    I had set up a client to use the automatic connection to Mac OS printers option, and we then discovered that once the printer was connected to the VM, he could no longer print from Mac OS. He would have to disconnect the printer using the printer icon at the bottom of the VMWare window before he could print from the Mac side. Then he'd have to reconnect it to the VM in order to print from Windows.

    I came up with a much simpler solution. After setting up printer sharing in Mac OS, together with Windows file sharing, I installed Bonjour for Windows in the VM. I ran the Bonjour Printer Wizard, and it added the printer quickly and easily. The client can now print from either OS without having to connect and disconnect.

    BTW, if you use Bonjour to share your Mac OS printers with Windows machines, by default it will try to use the "Generic Postscript" Windows drivers. This is correct. The job gets sent to the Mac OS using that driver, and the Mac takes care of communicating properly with the printer.

    Hope this helps someone.

    - Allen
     
  10. farmerrob macrumors newbie

    Joined:
    Nov 8, 2006
    #10
    Printing from XP produces random script

    I can print to my HP Laserjet 1012 from OS X without any problems, and I used to be able to print from Windows using Fusion without any problem until installing Snow Leopard. Now I can still print, from OS X, but when I print a file from Windows, pages and pages of meaningless script (text?) comes out instead.

    I have attached a picture of it. I am at a total loss on this. I have uninstalled the printers and reinstalled them.

    In my Fusion settings, I have Share Printers enabled. In Windows, the printer comes up as HP LaserJet 1012#:1

    Thanks for anything you can help with!

    - Rob
     

    Attached Files:

  11. bbgraves macrumors newbie

    Joined:
    Dec 2, 2009
    #11
    I have the exact same problem. Any help out there? Thx ~B
     
  12. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #12
    It's funny 'cause I have the opposite problem. Can print fine in Fusion, not in BootCamp.

    That's PostScript. Does your particular printer have a PostScript personality or just PCL?

    B
     

Share This Page