Printing problem with Samsung CLX3175 after lion install

Discussion in 'Mac OS X Lion (10.7)' started by paclemos, Sep 2, 2011.

  1. paclemos macrumors newbie

    Joined:
    Sep 2, 2011
    #1
    After updating my system for Lion i can no longer print to my printer. My samsung is connected to a hub via a USB cable that allows to print from for any one of my computers in my home network. There is no problem printing from a windows 7 system or from Mac OXS 1.6.8. I've been looking around for the several sugestions but trying to add the printer directly via print and fax control panel or via CUPS to the same thing for IPP, the print job is send to the printer and either the system can not identify the printer state or reports it as inactive and the print job is hold for ever. Also using LDP is also not working. Strangely if i connect the printer directly to my computer it works fine. Can it be a problem relayed with my hub that can not understand CUPS 1.5.0 as it changed from 1.4.7 when going from 1.6.8 to Lion?

    Any suggestions are welcome
     
  2. Dejan macrumors newbie

    Joined:
    Sep 15, 2011
    #2
    Hello Paclemos,

    Unfortunately, I do not have the solution, but I have the same problem as you do. So any suggestion would help me as well!

    I have a Samsung CL3175FW (wifi) multifunction printer. I cannot even install it under 10.7. In System Prefs I can see the printer (via IP), I choose the printer driver from the roll down menu (showing correctly by the name of the printer 3170 as drivers already installed from the samsung website), but when confirming the choice and adding the printer to the list in system prefs, a window pops-up showing OS X Lion wants to search & install the drivers for it, even thought they are already installed. Finally the system does not find them and aborts the installation. I tried to connect it via USB and ethernet and non works. On my other win xp pc, everything works smooth. This problem occured since I installed OS x Lion 10.7, as in SL 10.6.8 it was working.

    Any help is very welcomed!

    Macbook pro mid 2010 I5, 8Gb Ram, 10.7.1
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    Well open go to System Preferences->Print & Scan and right click and choose "Reset Printing system ...". Then go to the Samsung download page and reinstall the printing software and then re-add you printer.

    See if that helps.
     
  4. darster Suspended

    Joined:
    Aug 25, 2011
    #4
    I had the exact same problem with my Canon printer. The solution was to go into ~/Library/Printers and delete the Canon directory, empty trash, reboot, and then go to the canon site and download the new drivers. Everything worked after that. Just downloading the new drivers without deleting the directory would not solve the issue. So you may need to delete the samsung directory.
     
  5. paclemos thread starter macrumors newbie

    Joined:
    Sep 2, 2011
    #5
    Thank you satcomer and darster. I have already tried both of your suggestions before and they didn´t work in my case. Still printing via USB while not finding a solution... :(
     
  6. MH1972 macrumors newbie

    Joined:
    Apr 17, 2008

Share This Page