Printing problems after Leopard upgrade.

Discussion in 'Mac Accessories' started by Hopstretch, Oct 27, 2007.

  1. Hopstretch macrumors regular

    Hopstretch

    Joined:
    Apr 18, 2006
    #1
    After to upgrading to Leopard, I am no longer able to access my remote USB printer, which is connected to an Airport Express. I have reset the base station and it rejoins my network with no problems. But although my Canon MP780 shows up as a Bonjour printer, trying to add it fails to "client-error-not-authorized". A quick Google indicates this is a CUPS error message, but all the fixes are for Linux distributions. Any ideas how to resolve this on OS X?
     
  2. Hobofuzz macrumors regular

    Joined:
    Oct 9, 2006
    #2
    Has your username/computer name changed at all from what it was in Tiger when you upgraded?

    Looks to me like CUPS was configured to only allow printing from a certain user/computer.
     
  3. ksnowman macrumors newbie

    Joined:
    Oct 29, 2007
    Location:
    Michigan
    #3
    Similar issue

    Prior to installing Leopard, my MacBook found my Canon USB printer that is connected to my eMac just fine using WiFi.

    After installing Leopard, I can't find/add the USB printer, though it works just fine from my eMac.

    Help!
     
  4. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
    #4
    I've got a worse problem... I can't really print at all!
    If I go to Print in the File menu no matter which application it is... the application crashes. I assume it's some kind of driver incompatibility :(
    Instead I have to open the Printing Queue application and drag the file into the list... and that is hit and miss.
     
  5. RedDragon870503 macrumors 6502

    RedDragon870503

    Joined:
    Sep 6, 2006
    #5
    Same as above...

    I have a HP LaserJet 1000 that used to work flawlessly under Tiger using zenographics SDK Mono CUPS v1.1 driver.

    Now.

    Nothing.

    Anyone?
     
  6. judynewpt macrumors newbie

    Joined:
    Oct 28, 2007
    #6
    I can't get Leopard to recognize HP 1020 Laser printer

    I used the 1020 hp laser with Tiger no problem and even after downloading the driver I can not get Leopard to see it. Would love some help.
     
  7. splashtech macrumors regular

    Joined:
    Oct 25, 2007
    #7
    I have a printing problem too. I have two printers attached to my Vista PC (maybe thats the problem!) and printing to them as shared windows printers from leopard. It seems to think everything is fine when you send a print job, but nothing ever comes out of the actual printer.

    Very strange.
     
  8. naftalim macrumors 6502

    Joined:
    Sep 18, 2007
    Location:
    Vancouver, BC
    #8
    I'm not sure if this is related. I have a Brother Multifunction Laser connected directly to my iMac. After installing Leopard, I could see the printer in the list, but it woudl not print and the message was that it could not find the printer

    A quick look at the Brother site found an updated driver for Leopard, and after installation, worked perfectly.
     
  9. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #9
  10. RedDragon870503 macrumors 6502

    RedDragon870503

    Joined:
    Sep 6, 2006
    #10
    Yeah... I am honestly contemplating downgrading to Tiger... I need my printer more than I need all the Leopard Jazz...

    Anybody else use the Zenographics driver having trouble?
     
  11. Matzehali macrumors newbie

    Joined:
    Aug 1, 2007
    #11
    I can confirm that the Zenographics doesn't work with Leopard anymore.
    I hope someone can correct this issue.

    Hoping for that,

    Matzehali
     
  12. RedDragon870503 macrumors 6502

    RedDragon870503

    Joined:
    Sep 6, 2006
    #12

    Likewise...

    Anyone know who I could contact about this... zeno seems to not support this stuff anymore and hp is obviously not going to write a new driver for me....
     
  13. Gwgrayson macrumors newbie

    Joined:
    Oct 30, 2007
    #13
    Lexmark X2500

    I had the same problem with my Lexmark X2500. It worked perfectly with Tiger and I installed the driver on Leopard and when I would click File>Print the application would crash. Then I removed every file that the driver installed on the computer including the driver itself and there are no more crashes.

    I'm thinking it is a driver issue and that many of the companies need to release a driver compatible with Leopard.

    I had the same kind of problem with Quicksilver on startup. I had the option for Quicksilver to start up when the computer booted and it slowed down my boot process by a lot. Even when I open Quicksilver now it is very slow.
     
  14. Cave Man macrumors 604

    Cave Man

    #14
    Leopard kills Airport sharing

    Looks like Apple has really dropped the ball on this one. Not only is AEBS printer sharing dead, but so to is Airport Disk for many people. I have a Brother laser printer and 400 gig drive connected to my AEBSn and both are completely invisible to to Airport Utility.
     
  15. MLEE1974 macrumors newbie

    Joined:
    Oct 31, 2007
    #15
    HP 5610 MFC Problems

    Looks like there's an all around problem with Leopard and printer issues. I'm unable to print, although my Mac recognizes the printer. With Tiger I was able to load a document to scan...and my Mac would recognize a loaded doc, and allow me to scan from the screen...not now!

    I hope a updated driver rolls out soon! Don't want to fork out alot of money just to be able to print!

    But all in all...I love Leopard!:)
     
  16. hansmbg macrumors newbie

    Joined:
    Nov 5, 2007
    Location:
    Sweden
    #16
    Also problem with scanner Epson 2480

    I connect to the discussion of USB problems.

    After installing Leopard on my 1,8 GHz PowerPC G5 the Epson 2480 scanner
    is not found. The error message I get is that I have selected the wrong scanner.

    This is not so fun...

    I did download the driver from the Epson site, but that did not fix it.
    Now I am lost. The scanner itself wakes up when I do connect the
    USB cable to the computer, and that's about it, that's all.

    I hope this will be fixed very soon. I need the scanner...

    /Hans.
     
  17. GeenKwok macrumors newbie

    Joined:
    Nov 5, 2007
    #17
    i upgraded a couple days ago...and noticed that I couldn't print today thru my AirPort Extreme N router.

    luckily with a quick search i found that there is a solution on Apple's support site.

    what worked for me was
    1. deleting my printer from System Pref. - in Printer and Fax
    2. then adding it back.
     
  18. gdmedia macrumors newbie

    Joined:
    Nov 4, 2007
    Location:
    Austin, TX
    #18
    Problems with Brother MFC printer with Leopard

    I have a Brother multi-function machine, 8840D. New driver was bundled with Leopard but I later downloaded what appears to be a later one from the Brother website (CUPS driver v. 1.21), not that it fixed the problem.

    I used to be able to put paper on the manual shelf and it would detect that automatically and use it. If no paper on the manual shelf, it would use the internal tray. "Auto Select".

    But now, after the Leopard upgrade, Auto Select no longer works. The only way I can get it to detect and use paper (such as checks for printing) I have put on the manual shelf is to set the "Paper Feed" function to specifically use that manual shelf.

    Also, I see that the printer icon shows up in the dock and stays there unless I make it go away.

    Anyone else using a Brother MF machine under Leopard? How does it work?
     
  19. btfgus macrumors member

    btfgus

    Joined:
    May 16, 2005
    Location:
    Perth, Australia
    #19
    This really bites

    To print is one of the most simple functions. When u cannot it really F%#%$ up your day. Surely such an "advanced" OS could avoid such issues.

    Not happy at all.
     
  20. gdmedia macrumors newbie

    Joined:
    Nov 4, 2007
    Location:
    Austin, TX
    #20
    Brother Leopard Driver from Apple, not Brother

    I received this reply from Brother via email on 11-07-07:

    "Brother Customer:
    Thank you for taking the time to write to us. Unfortunately, there are
    no updated CUPS drivers for this unit. Therefore, the drivers are
    preinstalled by apple. The drivers that are preinstalled does not
    autoselect the manual feed tray. We will have an updated driver out
    soon for the printer which will give you the correct options for the
    printer.

    We hope this information will be useful to you. If we can be of further
    assistance, please let us know."

    So, that's interesting. The Leopard driver for this machine is something cobbled together by Apple, not created by Brother. We have to wait for that, after which "AutoSelect" will work again, hopefully. I wrote back to them asking when they thought the new driver would be ready. They replied that they did not have a release date for the new drivers yet but that it would be "soon". OK. I hope so.

    I imagine this same situation must apply to many, if not most or all, other printer drivers "bundled" with Leopard. If so, explains why many printers don't work quite right anymore.
     
  21. chriswelsh125 macrumors newbie

    Joined:
    Nov 9, 2007
    #21
    Fix for Leopard Shared Printer

    I had the same issue after upgrading the three macs at home, only one has a USB HP PSC 1400 connected and we shared this successfully under Tiger.

    I managed to resolve the problem for me by deleting the printer from the host and then re-added it, set the share-printer flag and then re-added the printer to the two remote macs.

    Works just like it did under Tiger now :->

    I think the issue lies somewhere between the upgrading removing all network printers from your Tiger data, then upgrading the local printers in Leopard, which keep the shared-printer flag set, however the upgrade does not re-add the shared printer definitions correctly. Removing and re-adding seems to cure that!

    Chris
     
  22. kivin777 macrumors newbie

    Joined:
    Nov 14, 2007
    #22
    my printer fix/work around for leopard

    i had the same issues printing in leopard until today... i deleted my printer(nrc sp219sf) and added it again but this time around i didn't use the driver that leopard selects for you(this one the one i downloaded from the nashuatec website when i first found i couldn't print(never needed one using tiger)) i then looked at the drivers that come pre installed on leopard and selected one from the nrg section and hey presto my printer works?,
    i don't know if this will work for everyone as all the printing issues seem to be slightly different, good luck!
     
  23. ChrisMcD macrumors newbie

    Joined:
    Dec 28, 2006
    Location:
    Harrogate
    #23
    Yet more Brother weirdness

    I have a Brother HL-2700CN, which has drivers on the Leopard install DVD - which the Brother website directs you to (no driver downloads for 10.5 from Brother?)

    I can connect to the printer, albeit with frequent crashes, but the black text has a red haze around it. Too much magenta!

    Luckily the 'generic drivers' appear to work OK.

    Brother technical support contacted me, they seem surprised!

    I believe this model is a 'badged' Tally and that there are similar Lexmark and Kyocera clones. Anyone tried their drivers?
     
  24. abletts macrumors newbie

    Joined:
    Nov 26, 2007
    #24
    Remote printing problems

    The solution posted above by GeenKwok worked for me. I could not remote print (to a HP USB Laserjet) after installing Leopard but removing and then re-adding the reference to the printer (on the remote machine) fixed the problem. Now, anybody have a solution to the permissions message reported by DiskUtility or my inability to copy files ;-)

    I knew I should have performed a clean install rather than an upgrade but there you go. Despite these few issues, for which I have workarounds, I still think it's worth it.
     
  25. jjdickson macrumors newbie

    Joined:
    Nov 28, 2007
    #25
    leopard/printers

    I have an HP photosmart 7350 printer, which is not supported by Leopard. HP told me leopard has a generic driver, which I loaded, but although the printer is recognised it does not print. Anyone got any ideas, apart from going back to tiger? Thanks, JD.
     

Share This Page