Printing problems ('Filter failed') on Yosemite

Discussion in 'OS X Yosemite (10.10)' started by MarkW19, Oct 21, 2014.

  1. MarkW19 macrumors 65816

    Joined:
    Sep 13, 2002
    Location:
    Surrey, UK
    #1
    Hi guys,

    I've had the public beta of Yosemite and the first perhaps 2-3 versions were okay, but then the betas after that (including the final public release which I've just upgraded to) I can't print from using my trusty Canon iP4200 - I get the attached error (Filter failed) when I try to print from any application, straight away before it even tries to print (and whether or not the printer is connected).

    I've contacted Canon and they stopped providing a dedicated driver at 10.7, so I'm using the OS X generic drivers and something obviously changed in one of the betas versions of Yosemite.

    Just wondering if anyone else has experienced the same issue with the same printer or another, and a workaround if possible? I would ideally prefer not to have to buy a new printer, particularly since it worked fine on the early Yosemite public betas (and continues to on my MacBook Air which is running Yosemite and I've kept to the old beta version for this reason).

    Hope someone can help! Thanks in advance.
     

    Attached Files:

  2. chandler99 macrumors regular

    Joined:
    Jun 6, 2009
    Location:
    York, UK
    #2
    i had a similar problem with a dell 2350n printer. I removed and reinstalled the driver and now it works fine.
     
  3. MarkW19 thread starter macrumors 65816

    Joined:
    Sep 13, 2002
    Location:
    Surrey, UK
    #3
    Hi, thanks for your reply. There isn't a Canon driver for anything past 10.7 unfortunately so I'm using the generic OS X drivers, so unfortunately I don't have anything to remove/reinstall as far as I know?
     

Share This Page