Privacy Caller ID *82 contact problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mgmacf, Jul 3, 2007.

  1. mgmacf macrumors newbie

    Joined:
    Jul 3, 2007
    #1
    I am surprised I could not find anything on this issue, I just got off the phone with Apple product specialists (while ATT was on the phone) and they verified and documented the problems.

    1. When you change the "settings/phone/Show My Caller ID" to "off" so no one can see your number, you CANNOT override it for specific calls. Normally, I used *82 as a phone prefix in the directory (or manually) to allow my number to sent to friends. This DOES NOT WORK! If you set the Show Caller ID off there is no way to override it, same goes for turning it on. You cannot turn it off selectively. IPhone seems to ignore any(most?) LASS(Local Area Signaling Services) prefix codes. Apple says that the *82 is the phone companies codes and the IPhone does not support it, however ATT says *82 is what to use. Bottom line: If you want default privacy for most outgoing calls and want to allow your number to go through for some calls, automatically or manually, this cannot be done! I don't really care what options we are given but I would like the same functionality as all other phones in this area of privacy. I suggested that the contacts (and mac Address Book) provide a setting for a contact to be sent your number anyway if calling iPhone is set to no send your ID by default.

    2. If you store a contact and the number contains an LASS code such as *82 in front of the phone number, when that call comes in iPhone DOES NOT match up the caller with the contact entry, so no name, picture or sound to identify the caller. All other phones support this. Again, this always worked on other phones.

    See this on LASS (Local Area Signalling Services):
    http://www.tech-faq.com/lass-codes.shtml
    http://www.asociacion-aecsi.es/doc/M...ss-codes.shtml
    Notes:
    [7] - *82 (1182) has been mandated to be the nationwide code for "Send CLID info regardless of the default setting on this phone line."

    *82 is a standard US (and I think international) code for all phone systems including landlines. This code can be used on almost all phones. For instance, my mother has calls with no caller ID blocked so I have to use *82. I have about 200 contacts many with *82, if you change them to #31# then they would ONLY work on a GSM line. Not good.

    Also, I tested #31# as a prefix in the contacts and when you call iPhones from that number the contact is still not displayed so #31# (or any prefix) voids the contacts entry (see item 2 above)..

    I don't know about you but this is a big privacy issue for me. If you call a store, etc. they get your number and can send junk mail, calls, etc. I normally had ATT set Caller ID block and have *82 added for certain entries I wanted unblocked.

    BTW, there are at least 2 Cingular phones (one is the 3100) that has the ID block in the phone as well but it ALLOWS you to set overrides in the contact directory selectively.

    Apple put these in as feature requests. I think item 1 was a big oversight and item 2 is a downright bug.

    Some suggested to use *67 to block calls which is not a solution if the phone blocks by default since you can't do the reverse (unblock a call) and... due to bug #2 you can't put *67 in a contacts and have the call recognized during incoming. Anyone else who does not like these problems please call Apple Iphone TS to let them know.

    Don't get the wrong idea, other than this problem (and 16 hours on the phone the first weekend to get 2 Iphones activated) my wife and I love the phones and will buy rev2. We will NEVER go back to "old" phones.

    Update and work arounds:

    1. If I set the iPhone to block all calls, and use the GSM code *31# in the contacts, the call is unblocked for that number. This does work and I can replace *82 with *31# in all the affected contacts. But.. It does not provide the callers name etc for an inbound call. Also tried to *31#+ (added +) but nogo. See next item.

    2. Since using a prefix in a contact prevents the contact from being displayed during an incoming call, I ADDED another number to that contact without the prefix. In other words, for a person I have 2 mobile numbers, *31#1408-123-4567 and 1408-123-4567. iPhone matched the second number and displays the callers name, etc. Still a bug but now I have a workaround. I will call Apple with the updated bug info.
     
  2. joelcsf macrumors member

    Joined:
    Jun 30, 2007
    Location:
    Bay Area
    #2
    I'm not sure where the *82 stuff comes from - maybe it's provider specific?

    According to GSM, if you prefix the number you're dialling with #31# it will withhold your caller id.

    If you prefix the number you're dialling with *31# it'll *SHOW* your caller id.

    I have tried the former and it works just fine for me. I haven't tried *31#. This is left as an exercise to the reader :)
     
  3. mgmacf thread starter macrumors newbie

    Joined:
    Jul 3, 2007
    #3
    See this on LASS (Local Area Signalling Services):
    http://www.tech-faq.com/lass-codes.shtml
    http://www.asociacion-aecsi.es/doc/Misc/Tech-FAQ/telephony/lass-codes.shtml
    Notes:
    [7] - *82 (1182) has been mandated to be the nationwide code for "Send CLID info regardless of the default setting on this phone line."

    *82 is a standard US (and I think international) code for all phone systems including landlines. This code can be used on almost all phones. For instance, my mother has calls with no caller ID blocked so I have to use *82. I have about 200 contacts many with *82, if you change them to #31# then they would ONLY work on a GSM line. Not good.

    Also, I tested #31# as a prefix in the contacts and when you call iPhones from that number the contact is still not displayed so #31# (or any prefix) voids the contacts entry (see item 2 above)..
     
  4. badtzmaru macrumors 6502

    Joined:
    Jul 1, 2007
    #4
    call at&t and have them remove your name so it only displays "wireless caller"

    thats what i did, i know its not the same as Unknown/Private caller but its better than doing a blanket block.
     
  5. mgmacf thread starter macrumors newbie

    Joined:
    Jul 3, 2007
    #5
    No it's not the same I dont want the number displayed. It is still 2 bugs in the iPhone that needs to be fixed. And they are not minor issues.
     
  6. rrr macrumors member

    Joined:
    Jan 17, 2004
    #6
    I would love for Caller ID to display my landline number instead of my cell number when making calls from the iPhone.

    Probably a long shot, but do you think AT&T would edit my CID data for my account upon request?


    rrr
     
  7. rrr macrumors member

    Joined:
    Jan 17, 2004
    #7
    By the way, I just tested *67 from the iPhone and it worked fine.

    ie: When I used *67, the call showed up as blocked, and when I didn't use *67 the CID was displayed.


    rrr
     
  8. mgmacf thread starter macrumors newbie

    Joined:
    Jul 3, 2007
    #8
    rrr, but you can't do the reverse (unblock a call) and you can't put *67 in a contacts and have the call recognized during incoming.
     
  9. dukeblue91 macrumors 65816

    dukeblue91

    Joined:
    Oct 7, 2004
    Location:
    Raleigh, NC
    #9
    Maybe I'm misunderstanding but you can turn your caller ID off and on at will in the settings of the iPhone.
     
  10. iappleforever macrumors newbie

    Joined:
    Jul 3, 2007
    #10
    this is a bummer....

    an apple fix would be for id to show if it is one of your stored contacts....plus be able to turn it off and on. i hate to get "wireless caller"......i am frankly waiting for a hack for Verizon before i activate lol
     
  11. mgmacf thread starter macrumors newbie

    Joined:
    Jul 3, 2007
    #11
    dukeblue91 I updated the original post to better explain and also figured out workarounds for people interested.
     
  12. joelcsf macrumors member

    Joined:
    Jun 30, 2007
    Location:
    Bay Area
    #12
  13. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #13
    I've used a cell phone for nearly four years and had never heard of any of this. Frankly, I think this might be more a "tinfoil hat" type issue, since no one I know has ever heard of this either.

    We live in a connected society. The price you pay for being connected is a lower level of privacy. Frankly, I'm fine with the trade-off.
     
  14. joelcsf macrumors member

    Joined:
    Jun 30, 2007
    Location:
    Bay Area
    #14
    My corporate cellphone (BBerry) syncs up with my client list every time I dock it.

    We have a policy that clients should not know our cellphone numbers. As such, the sync process automatically prepends #31# to every number not in the corporate directory/flagged as "personal" that it pushes to my Blackberry - i.e. client numbers. This has happened at two investment banks I have worked at.

    If a client calls me, the BBerry and every other cellphone I've ever had will display their name.

    The iPhone does not behave in this way. It displays the number on the screen will no caller id, if the client's number is programmed as #31#1415xxxyyyy in the iPhone.

    Fucntionality like this is a must for corporate users. The average user is probably never exposed to it though, granted.
     
  15. badtzmaru macrumors 6502

    Joined:
    Jul 1, 2007
    #15
    the iphone is not a business device. its not friendly to many business practices.
     
  16. B-Ri macrumors member

    Joined:
    Jun 26, 2007
    #16
    *67
     
  17. mgmacf thread starter macrumors newbie

    Joined:
    Jul 3, 2007
    #17
    *67 is a LASS code and suffers the same problems as *82 (the reverse of *67). All in the original post.
     
  18. dzoolander macrumors newbie

    Joined:
    May 30, 2007
    #18
    *67

    I have also noticed a problem with the iphone. As a physician I receive my pages from the answering service via text message. Hoeverver, on my previous phone I had asked the answering service to add *67 in front of the number so when I called the patient they could not see my number. However, with the iphone the *67 is in front of the patient's number but is not highlighted or underlined in the text message. Hence the number is not blocked. Any help would be of assistance. i do not want to block my caller id under settings ech time as this is inefficient and time consuming.
     
  19. SeattleInspect macrumors newbie

    Joined:
    Jan 20, 2014
    #19
    Unblock for Iphone outgoing calls

    I have it figured out now.... For T-Mobil using iPhone 5s have your main phone settings set to block all outgoing calls.

    Assuming your phone is et to block ALL calls in main phone settings:

    To unblock your contacts set the number as #31# (xxx) xxx-xxxx

    To make the call unblocked here is the trick. You cannot just click the name in the recent call directory you MUST click the info button next to recent caller name and call from there. For some reason calls will not work when just the contacts name is pressed.. MUST use the phone number directly.

    When the contact calls in name will still show who they are.


    Hope this helped you all!
     
  20. C DM macrumors Nehalem

    Joined:
    Oct 17, 2011
    #20
    Almost 7 years later...it's hard to know. ;)
     

Share This Page