pro audio issues with leopard - fixed yet?

Discussion in 'Digital Audio' started by discodave3, Feb 4, 2009.

  1. discodave3 macrumors newbie

    Joined:
    Feb 1, 2007
    #1
    I'm a sound engineer and laptop musician and I've been holding off upgrading to Leopard from 10.4.10 on my mb due to issues I've read about on certain sites with audio dropouts/driver problems etc. Its now getting to the point when I have to upgrade as pro tools 8 now requires Leopard and even 7.4 needs 10.4.11. Also Safari is starting to misbehave and I think I need the newer version, again which requires 10.4.11, but thats a whole other issue...

    As far as I can tell by google searches the main problem was with 10.5.2 and seems to have been fixed in the later versions - I assume the reported issue with 10.4.11 and Airport has also been fixed. Basically I'd just like some reassurance that this is indeed the case before I take the plunge and install Leopard! Has anybody had any issues? I use a 6 month old mac pro running latest versions of Leopard and pro tools 7.4 at work and everything seems to be fine but this is obviously a dedicated audio machine running nothing except pro tools hd, logic, toast, peak and itunes with no Airport, internet connectivity, web or e-mail etc; just wanted to check the situation on a general usage machine!

    My laptop setup is 2 year old blackbook 2ghz c2d with 2gb ram, MBox 2 mostly used in conjunction with pro tools le and Max/MSP (versions 4.6 and 5) and occasionally Reason and logic.

    Sorry for the complicated question - thanks for your help!
     
  2. WinterMute Moderator emeritus

    WinterMute

    Joined:
    Jan 19, 2003
    Location:
    London, England
    #2
    I've been running PT 7.4 on a MPB with a n M-box Pro since Digidesign reported compatibility with 10.5.3.

    Now running 10.5.6 with no problems.

    Can't comment on the USB variants directly, but the 60 or so M-box 2's we have in the labs at the Uni are working fine on iMacs and legacy G5 towers under 10.5.4.
     
  3. discodave3 thread starter macrumors newbie

    Joined:
    Feb 1, 2007
    #3
    thanks for that - anybody else have any experiences?
     

Share This Page