vancoder

macrumors newbie
Original poster
May 25, 2020
5
1
This question mostly to XDR display owners.

Have you guys experienced blue background artifacts on Apple Display (P3-500 nits) preset in the Apple Photos app?

I was testing presets and playing around to find the best preset for me and found that weird behaviour. I'm running a base MBP 16" model with i7 CPU and 5300 GPU.

Video #1: https://easyupload.io/gqswrp

Video #2: https://easyupload.io/8ovixc

To replicate:
  1. Change preset to P3-500 nits.
  2. Add photos to the Apple Photos app if you don't have it. I got a bunch of non-HDR and some HDR photos.
  3. Try to scroll through photos using left or right arrow buttons.
It looks to me that P3-500 preset has some troubles switching HDR and non-HDR content quickly and it throws such blue artifacts on bright (white) spots.

Also, after doing such photos scrolling I found that the screenshot border became blue, while it should be white. I attached 2 photos with the correct and incorrect screenshot border.

P.S. I cannot reproduce such behaviour on P3-1600, but still there is a minor, almost unnoticeable blue glare when scrolling non-stop.
 

Attachments

  • Screen Shot 2020-05-25 at 22.24.18.png
    Screen Shot 2020-05-25 at 22.24.18.png
    552.6 KB · Views: 161
  • IMG_3823.jpg
    IMG_3823.jpg
    264 KB · Views: 86
  • IMG_7484_2.jpg
    IMG_7484_2.jpg
    139.9 KB · Views: 67
Last edited:
  • Like
Reactions: wowlocal

wowlocal

macrumors newbie
May 24, 2020
7
1
Moscow
I saw similar effect when I had switch to P3-500 preset in whole operating system, can you send sample photos to test?
 
Last edited:
Comment

wowlocal

macrumors newbie
May 24, 2020
7
1
Moscow
Yesterday I updated my system to 10.15.5, can't reproduce this problem anymore, and also I've tested your sample in Photo App. Looks like the issue is fixed in the new update
 
Comment

vancoder

macrumors newbie
Original poster
May 25, 2020
5
1
Yesterday I updated my system to 10.15.5, can't reproduce this problem anymore, and also I've tested your sample in Photo App. Looks like the issue is fixed in the new update
Yes, I can confirm that this issue was fixed in 10.15.5.

Thank you for testing.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.