Proble with bootcamp on imac

Discussion in 'iMac' started by Christrong, Nov 25, 2016.

  1. Christrong macrumors newbie

    Christrong

    Joined:
    Nov 25, 2016
    #1
    Hello guys
    I am writing for desperation, I hope you can help me.
    Then I have an iMac 27 mid 2010 where I have always done the Bootcamp, installing Windows 7 and then 8.1.
    When one day I decided to replace the super-drive with a 512 GB SSD Crucial.
    After I installed OSX on SSD to increase the performance and fully formatted HDD 1TB which also shortly after he started to give me a malfunction.
    After that they are no longer able to install windows 10 on the SSD using Bootcamp always giving me the same error when I run the windows installation CD:
    "Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to gpt disk"
    I have tried everything to solve the problem trying to change the SSD partition table also completely reinstalling OSX also I was told that the problem could be the presence of two HDD in the iMac so I immediately removed HDD that was unused, but the problem persists.
    I hope you can help me because this problem is pulling me crazy!
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    This is without a doubt one of the most frustrating issues you will ever encounter on a Mac. It's an error that will inspire colourful language that doesn't bear repeating. BootCamp on legacy machines is a pain to install without a working internal optical drive.

    The easiest fix would be to replace the optical drive and put the SSD in the original HDD bay. From there, install Windows using BootCamp & a Windows DVD. Then take out the optical drive again. Yes, this is the easiest fix I know of!

    I had a problem installing BootCamp on my housemate's 2011 17" MBP. The optical drive was broken and it kicked up the same GPT error when installing Winblows through a USB ODD or a bootable Windows installer on a stick.

    I had to take out the SSD and put it in my 2012 15" with a working optical drive, then installed Windows through BootCamp. I then took out the SSD and put it back into the 2011, but Windows immediately bluescreened on startup. From there I accessed the BootCamp partition using Parallels Desktop. After going through and accessing the OS in Parallels, I fully updated Windows (WSUSOffline is a great tool for this, as Windows 7/8.1 will permanently stay on 'Checking for Updates' without finding anything), and then after updating, the BootCamp partition worked fine.

    This is a pain, pain, pain, and there's sadly no easy fix.

    Other things that I've previously tried which doesn't work (to save you some frustration, please take my word on this):

    1) Editing BootCamp plist file to fool the OS into thinking your Mac doesn't have an optical drive, then creating a bootable USB through that. You'll get the same GPT error, or it will say no bootable device upon restart. Won't work.

    2) Install through Apple SuperDrive. It'll just say your Mac isn't compatible for the SuperDrive. Won't work.

    3) Formatting/partitioning HDD with a blank FAT32 partition, booting into Windows installer on startup through USB key/ODD and installing it like you would on a Windows machine. Won't work.

    4) Copying Windows installer files to new internal HDD partition and booting into that partition through rEFIt/equivalent application. Won't work.

    5) Cloning an existing Windows install to HDD partition and booting into that. Won't work.
     
  3. Christrong thread starter macrumors newbie

    Christrong

    Joined:
    Nov 25, 2016
    #3
    Thanks a lot of response
    if you tell me that I can solve the problem by mounting SSD instead of HDD that I have already removed and reinsert the super drive inside the imac.
    it would be quite boring but if it's the only solution I will be forced to do so.
    unless someone knows a working method to install windows
     

Share This Page