Problem accessing NTFS formatted external hard drives on a new MacBook

Discussion in 'Mac Accessories' started by infobleep, Oct 20, 2009.

  1. infobleep macrumors regular

    Aug 10, 2008
    Hi there

    I have 5 external hard drives, which I purchased over time, for my 4-5 year old Toshiba laptop but only 1 out of the 5 is being accepted by my MacBook.

    2 are Seagate (USB) 320GB drives (identical models);
    2 are Iomega (USB and firewire) 500GB drives (identical models);
    1 is an Laice (USB) 1TB drive.

    All the drives are formatted to NTFS and connect to my Toshiba laptop without any problems.

    However when I plug them into my newly purchased MacBook the following occurs:
    1 of the 2 Seagate drives connect without any problems;
    The other Seagate drive appears in disk utility greyed out and Snow Leopard says it cannot mount it;
    The 2 Iomega drives appear in disk utility greyed out and Snow Leopard says it cannot mount them;
    The 1 Laice drive appears in disk utility and Snow Leopard brings up an error message saying there is an error with the disk and it needs to be repaired.

    Has anyone had a similar problem to this or have any ideas as to why this might be occurring? Clearly I'm not going to repair the Laice disk in case it corrupts the data on it. I did a search through the forums but couldn't see anything to help me resolve the problem but I may have missed something.

    I can't format the drives as they contain too much data across them. I'm intending to install MacFuse and ntfs-3g.

    Thank you for reading

  2. infobleep thread starter macrumors regular

    Aug 10, 2008
    Hi there

    Following on from my earlier post, I've got some more info, which may help explain what the problem might be.

    I am guilty of turning off the power to my external hard drives without firstly safely removing them. I wasn't aware that was required or if I ever was, I'd long since forgotten about it.

    So I safely removed my two imoega hard drives in XP before plugging them into the Mac. However they still failed to connect.

    By now I had installed ntfs-3g and macfuse and went to console to see what messages that gave me. It gave the following:

    20/10/2009 18:52:35[4012]	2009-10-20 18:52:35.347 ReportCrash[4012:2903] *** -[NSRecursiveLock unlock]: lock (<NSRecursiveLock: 0x1003095e0> '(null)') unlocked when not locked
    20/10/2009 18:52:35[4012]	2009-10-20 18:52:35.347 ReportCrash[4012:2903] *** Break on _NSLockError() to debug.
    20/10/2009 18:52:35[4012]	2009-10-20 18:52:35.347 ReportCrash[4012:2f03] Saved crash report for ntfs-3g[4013] version ??? (???) to /Library/Logs/DiagnosticReports/ntfs-3g_2009-10-20-185235_localhost.crash
    20/10/2009 18:52:35[4012]	2009-10-20 18:52:35.360 ReportCrash[4012:2903] Saved crash report for ntfs-3g[4011] version ??? (???) to /Library/Logs/DiagnosticReports/ntfs-3g_2009-10-20-185235-1_localhost.crash
    20/10/2009 18:53:55[4262]	2009-10-20 18:53:55.736 ReportCrash[4262:2903] Saved crash report for ntfs-3g[4261] version ??? (???) to /Library/Logs/DiagnosticReports/ntfs-3g_2009-10-20-185355_localhost.crash
    Opening one of those further gave the following info:
    Process:         ntfs-3g [4261]
    Path:            /usr/local/bin/ntfs-3g
    Identifier:      ntfs-3g
    Version:         ??? (???)
    Code Type:       X86 (Native)
    Parent Process:  fuse_wait2 [4260]
    Date/Time:       2009-10-20 18:53:55.723 +0100
    OS Version:      Mac OS X 10.6.1 (10B504)
    Report Version:  6
    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread:  0
    Dyld Error Message:
      Library not loaded: /usr/local/lib/libfuse.0.dylib
      Referenced from: /usr/local/bin/ntfs-3g
      Reason: image not found
    I also ran chkdsk on both hard drives but that found no errors.

    I'm still not sure what the problem is but think it may either be related to an unclean log file on the NTFS hard drives, due to not safely removing them.
  3. infobleep thread starter macrumors regular

    Aug 10, 2008
    Hi There

    I eventually soled the problem. For another one else with a similar problem this is what I did.

    I moved the files off one PC to another using windows explorer and then formatted the drive. After doing this Snow Leopard still didn't like it so I did the repair and it was then able to mount the drive. I then copied back the files.

    That was rather slow so I then used Microsoft's RichCopy to create exact copies with my hard drive.

    I then repaired the drive and found that it didn't corrupt my data. So I did this for the next two drives without copying and they were fine.

    However my final drive, which was 1TB, came up with a different error and the only option was formatting. It couldn't be repaired. Therefore I had to copy everything off it. After this I formatted it on m PC but still it didn't work so I installed MacFuse and NTFS-3G and formatted it in Snow Leopard. I then had to do a repair as before and it could now be mounted. Which just left me to have to copy back the files. All of this took time but at least it worked.

    Using the drivers on my XP PC machine, I've had to repair them since. Sometimes Windows explorer crashes or the USB ports malfunction. In such cases it's not possible to safely remove the hard drives. However at least repair works without the need to copy off the data.

Share This Page