Problem after Snow Leopard install

Discussion in 'macOS' started by gjh, Oct 10, 2009.

  1. gjh macrumors newbie

    Joined:
    May 13, 2008
    #1
    I just installed snow leopard on my macbook pro. Now, my installation cd won't eject. Every time I hit the eject button, right click and eject it, or drag the cd into the trash it makes the ejection noise, but doesn't eject. It then pops back up on my computer. I tried reinstalling 10.6, but that didn't fix the problem. I'm have a feeling it might be more than just 10.6's fault. Any suggestions?
     
  2. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #2
    Doesn't sound like a Snow Leopard problem at all. It sounds like a hardware issue and it just happened to occur with the Snow Leopard disc -- maybe your disc drive has been broken for a while and the Snow Leopard disc happened to be the one to confirm it.

    Try this: restart the computer, and while it's restarting, hold down the mouse button (or trackpad button). If the disc ejects, great. If it doesn't, you're probably going to have to get it looked at by a technician.
     
  3. gjh thread starter macrumors newbie

    Joined:
    May 13, 2008
    #3
    Yeah, that is what I am starting to believe. I was using a different CD earlier in the day and it was working just fine. It just must be a huge coincidence that it failed right after my install.
     
  4. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #4
    I don't think it is coincidence, I upgraded to SL and did not experience this problem.
    I did a clean install on SL, and found that I got the same problem, only after restarting did it eject, I restarted to install 10.6.1 - so maybe that solved it.

    Were you using 10.6.1?

    Kind Regards
     
  5. amusiccale macrumors 6502

    Joined:
    Jun 5, 2007
    Location:
    PA
    #5
    I've had issues with my MBP where the disk refuses to eject (attempts, but fails) after extended use (esp. ripping a DVD to an image), perhaps because of heat. After a few hours/overnight, it would then eject using the boot + mouse button command.
     

Share This Page