Problem and workaround for double-connection to network

dborja

macrumors 6502a
Original poster
Sep 13, 2007
859
19
Northern California
First, here's a clarification on my setup:

Wireless: connected to Internet gateway router
Ethernet: connected to AEBS. AEBS is serving a USB printer, an IP printer and two USB external drives. It is set up as a bridge between a network access point (which is also wirelessly connected to the Internet gateway router) and my iMac's Ethernet port; wireless on the AEBS is turned off. One of the USB drives stores my iTunes and iPhoto files.

Here's the problem:
In Tiger, Internet traffic goes through the wireless port and all else (print jobs and USB drive file traffic) goes through the Ethernet port automatically. After upgrading to Leopard, the iMac routes all traffic through the wireless port. This makes printing and USB drive file traffic extremely slow since the route is through the Internet gateway router then back into the access point and into the AEBS instead of directly through the AEBS which is connected to the iMac's Ethernet port. I had to disable the wireless port to "train" the iMac to use the AEBS then turn wireless back on after a while to recreate my Tiger connectivity set up. This worked fine until I installed the service upgrade to Leopard which reverted all network traffic through the wireless port. I had to re-train the iMac to use the Ethernet port. Of course, I've only had Leopard for a week so I don't know if I have to keep watching for this...

Question:
Is there a setting that I'm missing or is this a feature that I have to raise with Apple tech support?

TIA,
Dale
 

wetrix

macrumors 6502
Dec 1, 2006
422
0
Auckland, New Zealand
I am having a similar problem but turning off airport doesn't fix the problem. I have appletalk active on a direct computer to computer (both leopard) ethernet connection. When I was using tiger, I could quickly transfer files between the machines at gigabit speed. Now it goes at about 2mb/s and takes AGES! Even when I turn off airport.

Anybody worked out how to fix this?
 
Comment

dborja

macrumors 6502a
Original poster
Sep 13, 2007
859
19
Northern California
I am having a similar problem but turning off airport doesn't fix the problem. I have appletalk active on a direct computer to computer (both leopard) ethernet connection. When I was using tiger, I could quickly transfer files between the machines at gigabit speed. Now it goes at about 2mb/s and takes AGES! Even when I turn off airport.

Anybody worked out how to fix this?
I called AppleCare about the problem but they had no good answer for me. It seems that TS isn't fully up on Leopard yet... Meanwhile, in my network settings, I put the Ethernet connection above WiFi in my network preference list. This way, my file transfers go fast although Internet traffic also goes through the same port (Ethernet). I'm thinking that if the port traffic is full with file transfer, Internet traffic will finally spill over through the WiFi connection. Maybe 10.5.1 will fix this?
 
Comment

Similar threads

  • Ismail Gül
2
Replies
2
Views
279
  • wellander1
2
Replies
2
Views
419
Replies
1
Views
297
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.