Problem booting 64-bit Vista / Win 7 on MBP

Discussion in 'Windows, Linux & Others on the Mac' started by RealaT, Jan 10, 2009.

  1. RealaT macrumors regular

    Joined:
    Jan 6, 2008
    #1
    Hi all I seem to have a problem booting from my install DVDs of either Vista or Win 7 64-but editions on my MBP (santa rosa era I believe)

    Basically when I attempt to boot instead of getting the usual 'Press any key to boot from DVD' message, i get a menu appears like the following....

    1:

    2:

    Please select CD-ROM boot type:_

    and it just sticks on there, keyboard doesn't respond at all and probably wouldn't do anything useful anyway since both options are completely blank so I have no idea what it is asking me to do

    My Vista disc is a genuine original, my Win 7 disc is burned from the latest MS Public Beta, both do exactly the same thing

    Any ideas?
     
  2. drjsway macrumors 6502a

    Joined:
    Jan 8, 2009
    #2
    I have the same problem. Select CD-ROM boot type 1 or 2, but keyboard is frozen. Spent the whole day trying to fix it. Apparently, the x64 versions of Windows 7 and Vista SP1 try to force an EFI boot and Apple uses a different version of EFI, thus causing the problem. Or something like that.

    There is an article with a detailed workaround that involved rebuilding the ISO and forcing it to boot from BIOS.

    http://www.jowie.com/blog/post/2008/02/24/Select-CD-ROM-Boot-Type-prompt-while-trying-to-boot-from-Vista-x64-DVD-burnt-from-iso-file.aspx

    However, after I rebuilt the ISO, I got a "Cannot boot from CD - Code 5" error. Since Apple's EFI is incompatible with Windows 7 x64, I find it hard to believe that people are installing the x64 version without a workaround. I've tried on my MB, MBP, and MBA and get the same error.
     
  3. RealaT thread starter macrumors regular

    Joined:
    Jan 6, 2008
    #3
    Thanks for the info i'll try rebuilding the iso see i that works

    I don't think this issue affects all Macs as I can boot Vista x64 on my iMac just fine
     
  4. pugu macrumors newbie

    Joined:
    May 20, 2008
    Location:
    London, UK
    #4
    Macbook

    I've hit the exact same issue (Win 7 x64 on Macbook.) I burnt the disk to a DVD DL in disk utility. Are there any ISO editing programs for mac that are freely available? All the googling I've done has only pointed me to Windows Apps.

    I too am surprised more people aren't having this issue.
     
  5. rankl macrumors newbie

    Joined:
    Sep 4, 2007
    #5
    Same problem here

    running on 2.33 GHz MBP:(

    32bit downloading on the way
     
  6. nunzio23 macrumors member

    Joined:
    Oct 7, 2008
    Location:
    Orlando, FL
    #6
    Same problem here as well.. I did the exact same thing as drjsway with the same outcome.

    Has anyone had this problem and got it working?
     
  7. drjsway macrumors 6502a

    Joined:
    Jan 8, 2009
    #7
    Apple only started the new EFI thing with Vista x64 SP1. One idea would be to install Vista x64 original release, upgrade to SP1, to upgrade to Windows 7 without doing a clean install. However, that seems like a lot of work.

    The jowie article is for Vista x64 SP1 so it's possible Microsoft changed a few things for Windows 7. I'm sure there's a way to rebuild the ISO to have it work but I don't have the technical expertise to figure it out. Anyone with the time can play with the settings and try to figure it out.
     
  8. DreamLand macrumors member

    Joined:
    Jan 10, 2009
  9. jaisin macrumors newbie

    Joined:
    Mar 13, 2008
    #10
    I did the same thing, and now I am also stuck with Code 5. I am currently downloading the 32 bit version to see if that works. I've already burned through 4 DVDs trying to get this working!
     
  10. nunzio23 macrumors member

    Joined:
    Oct 7, 2008
    Location:
    Orlando, FL
    #11
    Thanks! I followed those instructions and it booted fine. Now another issue.. In the install process when it's expanding the files an error message appears.

    "Windows cannot install required files. The file may be corrupt or missing. Make sure all files required for installation are available, and restart the installation. Error code: 0x80070570"

    I did some research and most things say that the .iso might have not downloaded right but I have installed it on other machines without any problems so I don't believe that is it.

    Any suggestions would be great!
     
  11. Ryvius819 macrumors member

    Joined:
    Aug 5, 2008
    #12
    I installed the 64bit version with no problem, but when I loaded the leopard dvd into my unibody macbook, it said x64 bootcamp is not support, is there a way to fix it?
     
  12. steaney macrumors newbie

    Joined:
    Jan 11, 2009
    #13
    Same problem.
    But don‘t understand anything from the guide.. Maybe someone can explain for stupids?
    Would be pleasant!! :)
     
  13. gumbyx84 macrumors 6502

    gumbyx84

    Joined:
    Dec 7, 2008
    #14
    Found out an interesting workaround for this booting problem. If you use rEFIt in place of the Apple EFI boot loader, you can actually just choose to boot the main "partition" on the install DVD. When I booted with the disk in my superdrive, it showed there being 3 .EFI files on the DVD along wit the option to just boot from the disk. I choose the latter option and it installed without an issue.

    Hope this helps anyone having installation issues.
     
  14. Dragonforce macrumors 6502a

    Dragonforce

    Joined:
    Apr 9, 2008
    Location:
    London (Ealing) UK
    #15
    I installed Windows XP first and then from inside WIndows XP I installed Windows 7 x64. The old WIndows XP got renamed to Windows.old which you can delete after Windows 7 x64 finished installing.
     
  15. Link00seven macrumors regular

    Joined:
    Mar 6, 2008
    Location:
    Michigan, USA
    #16
    rEFIt gave me three options with the Windows 7 x64 version in the drive. First one started the rEFIt shell and didn't do anything. Second and third option caused my computer to hang. Where did you see the boot from disk option?
     
  16. gumbyx84 macrumors 6502

    gumbyx84

    Joined:
    Dec 7, 2008
    #17
    From the eRFIt boot screen. Would show you a screenshot, but no way to take one.
     
  17. steaney macrumors newbie

    Joined:
    Jan 11, 2009
    #18
    just take a phone- or digicam ;)

    for me its the same problem with rEfit as bootcamp..
    a shame! but nice try!

    i think theres no other option than installing xp or vista first...

    or any other idea??
     
  18. closet geek macrumors member

    Joined:
    May 31, 2007
    #19
    There are three options on the rEFIt boot screen which involve the DVD-ROM I have in my drive. One is to boot the standard Vista install I have already and the other two don't work.

    Can you give the exact name of the option you see that works or the shell commands you used to get it to boot please.

    Thanks!
     
  19. manlyman macrumors newbie

    Joined:
    Jan 13, 2009
    #20
    So rankl & jaisin... Did the 32 bit version work for either of you?
     
  20. jaisin macrumors newbie

    Joined:
    Mar 13, 2008
    #21
    I didn't bother installing it. I have a copy of Vista 64 bit. I tried to install that, and I got the Select CD-ROM error. I used the guide, made a new CD, and it installed fine. I don't really need to see Windows 7, and I don't want to install a 32 bit OS because I feel like that is going backwards. I'm just going to wait until someone finds a fix for the 64 bit version.
     
  21. gerginator macrumors newbie

    Joined:
    Jul 9, 2008
    Location:
    Orlando
    #22
    This has now become my problem. I finally got a version of x64 that will boot and start to install, but towards the end of extracting the files, I get the same 0x80070570 error as described above. Anyone have any idea as to how to work around this?

    I'm re-downloading the windows ISO and will re-burn it as slow as my superdrive will let me and I can only hope that will do it.
     
  22. sebsoccer1793 macrumors newbie

    Joined:
    Nov 30, 2009
    #23
    Same problem is last

    my version of windows 7 64 bit just got delivered today and so far i haven't got it able to boot. Unfortunately it happened with the same screen as the others with the select which cd/dvd to boot and the 1 and 2 above it. I know apple is opening a bootcamp that is going to be compatible with the windows 7 but i don't know if that will work. Can someone give a clear cut answer to the problem??????????

    thanks
     
  23. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #24
    Same here, my early 2008 iMac booted and installed Win 7 Home Premium x64 w/o any difficulty. Bootcamp 3.0 from SL installed without issue once I manually browsed to the bootcamp folder and ran the 64bit setup program. I already have 32bit Win 7 on my uMBP but I will try booting the x64 version just to see what happens.

    Cheers,
     

Share This Page