Problem booting MacPro with areca 1880ix-24 installed

Discussion in 'Mac Pro' started by marcksv, Apr 25, 2012.

  1. marcksv macrumors newbie

    Joined:
    Apr 25, 2012
    #1
    Hello!

    I have a problem with my new setup...

    I am running OSX lion server (10.7.2) on a mac pro server (model 5.1).

    I have a areca 1880ix-24 in a Netstor NA380A enclosure that controls 24 hard drives in a RAID0 config. (for testing purpose since my final config will be RAID6).

    My bootdisk is the internal HD in the macpro from factory. The RAID contains 0 items. Just formatted with disk utility.

    My problem is that when I boot the machine, I get a «no-entry sign». Then the boot just stays on that sign and the machine does not boot.

    I have found that if I hold Option key at startup, I then have the choice to boot from the bootdisk or the recovery disk. I choose bootdisk and the machine will boot.

    I have downloaded the latest drivers from areca (Mraid 1.3.4) and also have updated firmware, bootrom, bios, etc on the 1880ix-24 to V1.5 (tried 1.49 before). As for the BIOS, I have tried both the legacy version and the MacPro EFI BIOS from Areca. Both with the same result.

    I have also tried to do a clean install of 10.7.2 (internal HD, not on RAID). Then install MRAID 1.3.4 and as soon as I install the areca driver, the machine will not boot (no entry sign on boot). But if I hold option and select the bootdisk, it boots.

    I then restarted in verbose mode.

    It hangs when I get this message:

    IOSCSITargetDevice has encountered a device with hierarchical LUNs, yet the HBA does not support it(1).

    Then I get the «Still waiting for root device» message...

    I have set the SCSI /*LUN of the RAID to many different numbers with no success.

    I have tried to do a bootable clone of my bootdisk on the RAID array also and see if it would boot from there (with a SCSI /*LUN set to 0/0/0 and with the update of the macpro EFI from areca on the 1880). I then chose the OS located on the RAID as startup disk in system pref and reboot. The computer would then reboot... but NOT on the RAID system: It will reboot on the internal HD and I would not need to hold option!

    I use the RAID array for video file storage for shared video editing... So I don't wish to install OSX system on the RAID...

    When the areca card is in slot P2 or P4 in the netstor NA380A enclusure, the computer won't boot unless I hold option key and select the bootdisk. Selecting the bootdisk in System pref won't do it also. I really need to hold option key at startup for it to work.

    I get a no entry sign as if the system cannot find the bootdisk. I suppose it is looking at the areca card to find a system and since we don't boot from the areca well it just stays in a loop.

    If I put the areca card in slot P3, the computer will boot!

    Ideally I would like it to work with the card in slot P2 since the SAS cables will be too short to put the card in P3. I also don't see some logic as to why it would work in P3 but not in P2! Both slots are 8x

    I will try the same setup but in a mac pro running 10.6.8 tomorrow and see if I get the same problem... Might be Lion related.

    Any ideas?

    Thanks !
     
  2. Spacedust macrumors 6502a

    Joined:
    May 24, 2009
    Location:
    Poland
    #2
    Please use bless command to change booting disk. Check my posts.
     
  3. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #3
    Thanks for the reply! I'll try that tomorrow morning when I get to work!
     
  4. cutterman macrumors regular

    Joined:
    Apr 27, 2010
    #4
    You probably need to flash the card with the mac pro efi bios. You can find it at FTP.areca.com.tw.
     
  5. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #5
    Thanks for the reply!

    I know my story is quite long... but I did tried the mac pro efi bios with no success.

    I don't want to boot from the RAID also. Just use it as a shared storage for video editing...
     
  6. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #6
    I gave the bless command a try... Following one of your posts, here is what I did:

    sudo su

    bless -device /dev/disk4s2 -legacy -setBoot

    I changed disk4s2 to reflect my boot disk (disk0s2). This is the Apple_HFS partition where my system is installed.

    I rebooted and the computer did not boot. I got some messages (see links to pictures) saying that : No bootable device -- insert boot disk and press any key.

    The thing is I have unplug all of the drives that connected to the Areca. I have only my boot disk available...

    It seems that the Areca prevails when the mac boots as if it is stopping the mac from seeing it's own boot procedure... The only way I found to be able to boot the system is to hold option. I also discovered this morning that if I hold Eject on the keyboard, it would boot to OSX... It seems that pressing a keyboard key that has a function on boot for OSX takes over the Areca card...

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  7. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #7
    I tried putting the adaptor NA380a PCI-e x8 host adapter in a mac pro running 10.6.8 this morning. Booted the machine. Installed the Areca drivers. Rebooted. Everything went fine!

    It seems that in some way Lion has a problem booting when the Areca is in the loop...

    Any ideas?
     
  8. Spacedust macrumors 6502a

    Joined:
    May 24, 2009
    Location:
    Poland
    #8
    Maybe just select the correct startup disk in Mac OS ?
     
  9. cutterman macrumors regular

    Joined:
    Apr 27, 2010
    #9
    It still seems like the card BIOS is for booting on PC's. Did you use Firefox to flash the mac pro efi BIOS? Sometimes Safari is flaky with the web manager.
     
  10. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #10
    Really. Were you successful with the efi flash? Your statements are strange. Did you flash and booting is unsuccessful or was the flash itself unsuccessful. Because you can't forego the efi flash and expect it to work. It wont.
     
  11. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #11
    I tried that with no success... I really have to hold the option key to prevent the computer to try and boot from the card.

    ----------

    Yes, I used firefox. We have been using areca cards since about 3-4 years now with great success (1280, 1680, 1880). And when I did update the 1880, I get the successfully updated bios, firmware, etc... message.

    Since I have successfully booted a 10.6.8 computer with exactly the same setup I would suspect some sort of difference between the boot sequence in 10.7.2 vs 10.6.8... At least at the very early boot sequence...

    ----------

    All updates of the bios, efi bios, firmware, etc... were successful. Booting the machine was not.

    The machine did not boot with the legacy bios nor the efi bios.

    I am booting from the internal macro drive that came with the machine. Not from the enclosure. I have no operating system on the enclosure.
     
  12. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #12
    I still haven't found a solution for my problem except holding the option key to select the boot disk as startup.

    Does someone know what are the boot sequence different between 10.6.8 and 10.7.3? Because 10.6.8 worked perfectly with all the same gear...

    Thanks!
     
  13. cutterman macrumors regular

    Joined:
    Apr 27, 2010
    #13
    FWIW, I have a test volume of 10.7.2 residing in an expander case connected to the external port on an 1880ix card and it boots fine.
     
  14. marcksv thread starter macrumors newbie

    Joined:
    Apr 25, 2012
    #14
    That's weird... Maybe it's because all of my cards are -ix24 version... I have tried with a 1280, 1680 and 1880. All ix24 and as soon as I put it in, I have to hold option key for the macpro to boot.

    On a 10.6.8 machine I don't have this problem with all the same hardware...
     
  15. Lane Roathe, Jun 19, 2012
    Last edited: Jun 21, 2012

    Lane Roathe macrumors newbie

    Joined:
    Sep 15, 2011
    #15
    Same issue here...

    I am having the same issue with my ARC-1223 8i, with a few differences:

    - I can set the boot volume to a volume on a Firewire 800 device and the machine will boot fine.

    - I can't boot to a volume on the internal SATA connections or to a pass-thru volume connected to the ARC-1223.

    - Holding down Option and selecting a volume from the resulting icon list does not work for me, the boot process still hangs at the "Still waiting for root device..." stage.

    Basically, if a volume on any non-RAID SATA device is specified as the boot volume then the machine will not boot.

    I have tried firmware 1.49 and 1.5 and I know I have the EFI properly flashed (verified by booting to a volume on a Firewire 800 device with rEFIt installed).

    UPDATE:

    It turns out the issue was with my Seagate 1TB drives (model ST31000528) attached to the ARC-1223. After upgrading their firmware (who knew hard drives had upgradable firmware?) from CC34 & 35 to the latest (CC49) I can now boot to a non-RAID device.
     

Share This Page