Problem changing MobileMe to gmail reply-to

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rKunda, Mar 1, 2009.

  1. rKunda macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
    #1
    I've gone through over a dozen articles and forum threads like this:

    http://www.macosxhints.com/article.php?story=20080720093316215

    I am trying to route all email through gmail to my mobileme account.

    I've got forwarding working (via a filter) so all email sent to my gmail is forwarded to mobileme. That works great. I've also got it working on my mail.app—I'm using my mac account but it sends all email as a gmail email using the gmail smtp server.

    So we get to the iPhone. I'm getting all email okay, but when I sent out emails it appears at myname@mac.com not as a gmail address. However, it appears to be set up correctly. I've added all addresses to my accounts in gmail and adjusted all reply-to settings, and emails sent from my mobileme account on my iphone (and mail.app) appear in gmail's sent folder, yet when coming from the iphone, they don't appear as a gmail-sent message.

    Any thoughts?
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    So if I understand this correctly, you redirect all your Gmail to your MobileMe account and when you want to send from your MobileMe account you want it to show that it was sent from your Gmail account?

    If so, why not just simply add your Gmail IMAP to your iPhone's email accounts?
     
  3. rKunda thread starter macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
  4. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #4
    Yeah, I know. :)

    I also use Gmail and MobileMe. MobileMe is my "main" account since it pushes, Gmail is a secondary account (LJ, Macrumors, Slashdot replies) that I can live with on a 15min pull.
     
  5. rKunda thread starter macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
    #5
    I've been doing that for a while, but I'm tired of having multiple email accounts—and I like gmail's infinite archivability. So I want to switch to switch to gmail but retain push.
     
  6. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #6
    Fair enough I suppose. Did you got go Settings, Mail, Your MobileMe Account, Account Info, Outgoing Mail Server SMTP and change to Gmail's SMTP server? Your link above has a typo in it so it should be smtp.gmail.com.

    Or you could always just choose Gmail's SMTP server when you draft a message. :)
     
  7. iFerd macrumors 6502a

    Joined:
    Jul 20, 2007
    #7
    In my experience, this does work, but only if the gmail account is set up fully on the iPhone. I suppose you could set it to check for mail manually and then never check it. You can also change the SMTP server manually when you are replying to a message by tapping on the Cc/Bcc, From: line and selecting the desired server from all of your configured accounts that appears when you do that.

    I understand push and what it can do as a former BlackBerry user, but I've found that for me, a 15-30 minute polling interval is plenty soon enough. But I've turned off the desktop notices at work too, in an attempt to be less a slave to email, so YMMV.

    I have a slightly different problem with replying: I'd like to be able to use a gmail account to which I forward work email. But I can't make replies seem to come from the work account because there is no way to set up the work email on the iPhone.
     
  8. rKunda thread starter macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
    #8
    Thanks for the tips, but it's still not working.

    The only outgoing server that's on is the gmail one, and indeed all mail sent is being routed through gmail because I can check the sent folder on my gmail account and see it, however, those sent from my iphone still appear as @mac.com.
     

Share This Page