Problem connecting Simpletech external drive to macbook

Discussion in 'Mac Basics and Help' started by jplavoie, Jan 1, 2008.

  1. jplavoie macrumors newbie

    Jan 1, 2008
    So I just bought a SimpleTech Simple Drive 60gb to use on my MacBook with Mac OS X 10.4.11. I followed the instructions and plugged the Mini-B part of the USB cable in the hard drive and the other end of the USB plug in my MacBook. The instructions tell me I am supposed to see the drive pop up on my desktop but I see absolutely nothing.
    Am I doing something wrong?
  2. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    Either the drive is not formatted yet (open Disk Utility on your Mac. Do you see the external drive in your list of devices? If there is nothing on this drive yet, you can Erase (format) it to Macintosh Extended (HFS+) )

    Or the drive is not getting enough power from USB and is not spinning up. Did it come with an AC adaptor?

    Or the drive is defective.

    More detail needed. Can you hear the drive spinning? Is there a light? What happens if you plug it into a different Mac?
  3. jplavoie thread starter macrumors newbie

    Jan 1, 2008
    I cannot find it in the Disk Utility panel, and it did not come with an AC adaptor. The USB cable came with a second USB plug to use as a power source but that made no difference.

    When I plug it in, a light turns on on the external drive and I can hear/feel it spin.

    I tried plugging it in my home computer which is a PC and it recognized it.

    Maybe I should just bring it back to the store?
  4. DataThief macrumors member

    Jul 30, 2007
    Somewere in Washington State
    I just bought the 250gb version today, when I plugged it into the left side usb port on my MBP I get the same response as you, I then plugged it into the right side usb port and it came up no problem, TM is now backing up to it. I think that left side port does not supply enough power to run the drive, it does work with mice and my other powered usb drive however.
  5. jplavoie thread starter macrumors newbie

    Jan 1, 2008
    Ahh I guess the lack of power might explain why it's not working. The only problem is that I only have a Macbook and there are no USB ports on the right side, only the two on the left side. I will try to use an extra power cable and see what happens.
  6. fhprintmkr macrumors newbie

    Feb 21, 2008
    More power, Scottie!

    Bottom line... get an external power adaptor (5 VDC, 1.0 A).

    I had same problem with my PowerBook G4 and SimpleTech PininFarina 120GB. I purchased a "Universal AC/DC Adaptor" made by some company called XG for $20. US.

    The thing that confused me most was that the MAC saw the device, but not the volume. That is, with both the Data/Power and Power-Only USB plugs connected for more power per the instructions (Quick Start guide, a PDF available from their Tech Support site), the System Profiler saw that there was a storage device attached, but the volume did not load and the system did not see the files and directories on it.

    Also, the red power light on the drive comes on, but the blue data-read light never shows. This seems to mean there is not enough power to actually run the drive. You can only tell the drive is actually working by the whirring sound it makes, which you would not know since you have not heard it yet.

    I was able to figure this out only because I got a new MacMini, and having forgotten the SimpleTech drive did not work on the PowerBook G4, I hooked it up to the Mini and it accessed with no problem. I had earlier thought it was a drive format issue, but once I got it on the MacMini, I was able to format the drive just as the documentation describes.

    The power adaptor I got can be switched for different voltages, and had a range of connectors, which included the right size for the SimpleTech. The connectors are separate pieces and attach to a cable coming from the adaptor. The connectors and cable are poorly marked and reversible, so figuring out polarity without risking the drive was a challenge. I used a USB hub I had handy, which had an LED in it. If the LED lit, I knew I had the power supply connector on the cable correctly. The important thing is the power supply be switchable to 5 VDC. My power supply is rated at 2500mA (2.5 Amp), and the drive only draws 1 Amp of current.

    I hope this helps.

  7. TofuGirl macrumors newbie

    Dec 19, 2009
    nothing works sigh

    Well, the light is on demonstrating it has power, and I've tried a couple different USB cords and slot, and my G5 on OSX just can't see the drive. AAAACK! :mad:

Share This Page