Problem Converting Movies in Quicktime X

Discussion in 'macOS' started by Luigi239, Nov 7, 2009.

  1. Luigi239 macrumors 6502a

    Joined:
    Jan 25, 2007
    #1
    I'm trying to convert a xvid movie into .m4p using Quicktime X in Snow Leopard. The conversion finished and I suppose that the application tries to move the file, but then I get this error (I shortened the file name):

    Can’t make file "Macintosh HD:private:var:folders:...m4v" into type alias.

    What's going on? I've converted many videos before this way and never had a problem. Thanks.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Are you able to play back the Xvid .avi file via QT X?

    Have you tried the QT 7 version in Utilities?

    You could also give MPEG Streamclip a try.
     
  3. Luigi239 thread starter macrumors 6502a

    Joined:
    Jan 25, 2007
    #3
    Yes, I am able to play back the file, and convert the file. The conversion doesn't fail until the very very end where I'm assuming for some reason it cannot move the new converted file.
     
  4. Dr Strangelove macrumors regular

    Joined:
    Jul 24, 2008
    #4
    I just started having the same problem today. Has there been a fix for this? It was working fine since last year. But today it will not work even after repairing disc permissions
     
  5. vasche macrumors newbie

    Joined:
    May 26, 2009
    #5
    Same error

    I'm getting the same error. Solution anyone?
     
  6. vasche macrumors newbie

    Joined:
    May 26, 2009
    #6
    I've search all over for the fix to this, to the end of Google and back with no luck. I ended up using Export in Quick Time 7 and adding to iTunes manually, but this is mind boggling that this issue has no recorded solution on the internet.
     
  7. disconap macrumors 68000

    disconap

    Joined:
    Oct 29, 2005
    Location:
    Portland, OR
    #7
    Not a fix, but Handbrake is open source and uses the QT engine to do compressions (and has a ton of cool presets)...
     
  8. Zodama macrumors newbie

    Joined:
    Jul 3, 2010
    #8
    I have the exact same problem that just started a couple months ago. My Handbrake settings used to work then they stopped working- I could rip and play on my computer just fine but could not transfer to ipod even with the ipod settings. Then, I started to use QT X to convert my Handbrake rips to ipod. Then QT started acting up. I am trying QT 7 now but it seems weird to me that we have to go backward when forward was working.
     
  9. MacRomio macrumors newbie

    Joined:
    Jul 6, 2011
    #9
    Solution: Repair Disk Permissions

    I had the same problems mentioned here. Quicktime would convert almost the entire .avi file and then stop and spit back an error that it couldn't create the alias and wouldn't complete the .avi to .m4v conversion.

    Someone mentioned Repairing the Disk Permissions... I tried it and it worked!

    Go to Utilities > Disk Utility > Select the drive, then click Repair Disk Permissions.

    It took about 20 minutes to repair the permissions. I then restarted my MBP for good measure and retried converting the .avi file and it worked.
     

Share This Page