Problem deleting partitions

Discussion in 'OS X El Capitan (10.11)' started by SZS, Oct 8, 2015.

  1. SZS macrumors newbie

    Joined:
    Oct 8, 2015
    #1
    Hi.

    I have a Mid-2009 Macbook Pro 13".

    I was using Mavericks and decided to give El Capitan a try and at the same time to perform a clean install because my computer was running slow and I don't even remember when was the last time I did a clean install of the system.

    I was afraid that the new OS would not run properly and that my old apps would not be compatible so I decided to create a second partition on my 1TB harddrive and install it there.

    So far so good. The operative system was installed, I made it the Startup partition and I copied all the data from the previous Mavericks partition into the new El Capitan one.

    I then proceeded to try to delete my previous partition with Mavericks. I opened the Disk Utility and erased the partition. Then when I wanted to completely delete the partition and have just the partition with El Capitan I noticed that the "-" in Disk Utility was greyed out. I did not understand what was happening so I tried to just reduce the space of the empty Mavericks partition to the minimum, but instead of having now a small Mavericks partition with around 6GB and an El Capitan one with 994GB I got a third partition "Untitled" that also has the "-" greyed out. So now I have 3 partitions and I can'tt delete the 2 I don't need. Curiously the only partition where the "-" is not greyed out is exactly the one I want to keep.

    I was searching and found people with similar problems but somehow I can't find a straight forward answer on how to solve it.

    I am currently making a Time Machine backup of the El Capitan partition (I excluded from the backup the 2 others I don't need on the time Machine options) and thinking that I should just completely wipe the disk, reinstall El Capitan and restore everything from the Time Machine backup.

    Meanwhile can someone tell me if there is a possibility to delete these 2 partitions without wiping everything and restoring from Time Machine?

    Thank you in advance.
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    If you put your computer into my hands, I would:

    1. Create a CLONED BOOTABLE BACKUP (Time Machine won't do) using either CarbonCopyCloner or SuperDuper onto an external drive.

    2. BOOT from the external clone.

    3. RE-initialize the internal drive into a single partition.

    4. RE-CLONE the backup drive BACK TO the internal drive.

    This will take a little extra time, but it -WILL- accomplish what you want to do.
     
  3. randomgeeza macrumors regular

    Joined:
    Aug 12, 2014
    Location:
    United Kingdom
    #3
    Agreed. The first partition of your HD is the primary and as such cannot be deleted... Hence the greyed out options in DU.
     
  4. SZS thread starter macrumors newbie

    Joined:
    Oct 8, 2015
    #4
    Thank you for your replies.
    And if I:
    1. Install El Capitan in an external harddrive.
    2. Make this external harddrive the Startup harddrive and boot the computer from it.
    3. Open Disk Utility and format the Internal harddrive so it has only one partition.
    4. Install El Capitan in the internal harddrive through am installation file saved in the external startup hdd.
    7. After having the osx in the internal harddrive I make it again the Startup disk and boot the computer from it pressing cmd+r.
    6. Use Migration Assistant to restore all settings and data from the Time Machine backup I have in other harddrive.

    Will this work as well? I was trying to avoid to make the clone because I have around 500gb of data and each time I do a clone or backup it takes around 7 hours while the Time Machine backup is already done.

    Thank you for the help.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Once you get the Time Machine backup done under El Capitan, reboot while holding the option key and select the Time Machine drive to boot from. That will boot to a recovery partition on the Time Machine back. From there use Disk Utility to erase the entire disk to one Mac OS Extended volume. Then quit Disk Utility and click restore. That will put the OS and all your apps and data back on the now single partition. There is no need to reinstall the OS if you do this.
     
  6. SZS thread starter macrumors newbie

    Joined:
    Oct 8, 2015
    #6
    Hi weaselboy.
    Thank you for your suggestion. Unfortunately I tried to boot from the Time Machine disk and it does not work. The computer will not bort from it. The screen turns gray and shows only a forbidden sign.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Hmm... too bad. What TM does is pull over the recovery partition from the main install on the internal drive. Sounds like maybe with all you have done, you may not have that partition any longer.
     
  8. SZS thread starter macrumors newbie

    Joined:
    Oct 8, 2015
    #8
    Thank you all for your replies. I was able to revert the internal harddrive to one single partition using the method I described. I assume that using the CCC method could have been faster if the disk to clone was not full with 500gb but I already had a Time Machine backup done so I went the other way.

    Thanks!
     

Share This Page