Problem Enabling SuperDrive.

Discussion in 'MacBook' started by goldjacket, Feb 4, 2013.

  1. goldjacket macrumors newbie


    Feb 4, 2013
    A couple months ago I disabled the SuperDrive on my MacBook 4,1 because I have a DVD stuck and it wouldn't stop reading it. I did this by moving the "IODVDStorageFamily.kext" and "IOCDStorageFamily.kext" files out of the /System/Library/Extensions folder. Now I want to copy the disk image from the DVD in the drive to a USB drive and to do this I need to reenable the SuperDrive. I put the .kext files back in the Extensions folder and rebooted, but nothing happens. I know that the drive reads the disk because it shows up when I boot into my Linux partition. Is there something I'm missing?
  2. gregoryvwalters macrumors newbie

    Apr 18, 2013
    any luck?

    I'm having the same issue. Did you resolve yours somehow? I removed that file from extensions and put it somewhere else to disable my superdrive (I wanted to use an external drive...which it's still not recognizing). So I tried to re-enable the superdrive by placing the file back in extensions. No luck so far. I have a blank DVD in the superdrive and I can't even eject it.

Share This Page