Problem erasing/formatting external HD in Mac OS 10.4.6

Discussion in 'Mac Accessories' started by valente.mac, Jul 9, 2006.

  1. valente.mac macrumors newbie

    Jul 8, 2006
    Hello --

    I'm hoping someone in this forum can help me, since I've searched and searched over the net looking for an answer and, 'til now, nothing...

    I have an Iomega external HDD120GB USB (model: DHD120-U). It was being used as general backup HD on a FAT32 format since I had a laptop with Windows XP. Now I switched to MacBook Pro (lntel; on OS 10.4.6) and decided to clean the HD to use as backup -- first by hand removing the data there and then following the general procedures to format on Mac:

    1) Mounted the HD in my Mac (it was working okay on the Mac, even in FAT32 format) and opened the Disk Utility application...

    2) Tried to simply erase the volume of the HD as Mac Os Extended (Journaled): the application froze.

    3) Tried again to erase the volume of the HD as Mac Os Extended (Journaled), but this time changing the option under "Secure Erasing Options" to "Zero Out Data": the application started and the HD was acknowledging the process (blue light twinkling). It said it would take about 2 hours to finish it, so I got along with my life and returned 3 hours later to check it. The process was still in it, but the bar (displaying the time to end the process) didn't move. After awhile I turned it off.

    4) Did the same thing over the night (over 6 hours): by the morning the process was still going. Turned it off again.

    5) End result: When I connect the HD to the MacBook Pro, it pops out a windows saying "Disk Insertion: the disk you inserted was not readable by this computer." It gives me three choices: eject (no point in there), ignore (nothing happens, since the volume doesn't mount), and initialize. This last launches Disk Utility app. I can then select the HD that now has the name "WDC WD12 00BB-22GUA0 Media." It does not allow me to do anything on "First Aid", on the "Erase" it gives me the error above (only tried it on Mac Os Extended (Journaled), though) and it freezes on the "Partition." "RAID" or "Restore" are not allowed either.

    6) Tried to format it again on Windows. It doesn't recognize it as a volume under "My Computer", although it does recognizes it as a USB volume that can be disconnected -- the location of it is (weird!) 0. So I can disconnect it, but not format it (or write or erase).

    Does someone have any idea on what to do now?

    My thanks in advance...

    -- M.J.
  2. tainice macrumors newbie

    Jul 6, 2006
    Why don't you:

    1) try to install any new driver/firmware for the driver,

    2) try to formate the driver using the OS X installation DVD,

    3) update to 10.4.7 and see if that makes any difference, and finally,

    4) try to partition the driver to "free space," then plug it back to a PC/Mac and then formate it again.

    5) Call Iomega.

    That's all I can think of now.

Share This Page