Problem erasing hard drive.

Discussion in 'Mac Basics and Help' started by LosAngeles91, Aug 2, 2011.

  1. LosAngeles91 macrumors newbie

    Joined:
    Aug 2, 2011
    #1
    Hey guys,

    I have troubles erasing my external hard drive Seagate 640gb using USB 2.0. This drives has no data in it. I'm not very good in computers.

    So I tried using disk utility "Erase" function to erase into Mac OS extended (journaled). But the loading bar just kept going

    I went to the partition tab to apply GUID type (I'm not sure the meaning of it, but I know its something to do with Intel Macs as stated by disk utility). The loading bar appear but it just kept loading but showing no progress for a few hours.

    Lastly, I tried using the last resort that I search in the internet, which is terminal using "diskutil eraseDisk HFS+ newdisk disk1" but to no avail.

    So basically the bar just kept loading for few hours. Normally after loading bar, there is a progress bar.
    I'm stuck at loading bar for like 2-3 hours.
    Is this the right way to format a drive?

    By the way, I'm actually trying to clone my macbook internal drive to this SEAGATE 640gb drive so that my macbook can boot from this external drive instead of my internal drive. I'm running Max OS X Leopard 10.5.8 by the way. Pardon for my english.

    Help would be appreciated. I'm kind of running out of ideas.
     
  2. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #2
    See if you can erase the external while booted from your OS install disc. Repair your internal while you're booted from the install disc as well.
     
  3. LosAngeles91 thread starter macrumors newbie

    Joined:
    Aug 2, 2011
    #3
    Hey, thanks for your help.
    But is there another way which doesn't require a mac os X installation disc?
    Because its not with me.

    There is no problem with my internal disk drive, but I just want to clone it for backup.
     
  4. LosAngeles91 thread starter macrumors newbie

    Joined:
    Aug 2, 2011
    #4
    Disk utility seems to hang down there. It seems like its not working at all.
     
  5. Knoodles, Aug 2, 2011
    Last edited: Aug 2, 2011

    Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #5
    "There is no problem with my internal disk drive"
    I didn't say there was. I just wanted you to run repair while in Disk Utility.
    When booted from the internal go to Disk Utility and select your HD in the left column. You see the repair disk button? It's grayed out. You can verify though. Do the verify. If it says something needs to be repaired (in red) then you will need the install disc to do the repair.
    As for your other question
    Use an install disc.
    Use Target Disc Mode.
    Use an external drive.
    Probably more can't think of any at the moment.
    You could try creating a new "test" administrator user account and see if the external will erase while logged in to it. Might be something wrong with your account. A long shot but worth a try.
    If there is something wrong with the HD, System, or user account I wouldn't clone until they are repaired.
    Have you repaired permissions?
     

Share This Page