Problem erasing MacBook drive while booted from external drive

Discussion in 'macOS' started by jasonkstupski, Aug 4, 2009.

  1. jasonkstupski macrumors newbie

    Joined:
    Aug 4, 2009
    #1
    Hello,

    I'm booted on a MacBook Pro from an external drive, and I want to erase the drive inside the MacBook using Disk Utility from the external. For some reason or another, it won't let me do this.

    When I click on the Erase tab (whether clicked on the disk itself or the volume "Macintosh HD") and try to erase it, it returns with the error:

    Disk Erase failed
    Disk Erase failed with the error:

    Could not unmount disk.

    When I try to install an image onto the drive, I get a similar error, except it says "Operation not permitted."

    When I tried it while booted with an OS X DVD, it worked fine.

    As far as I know, I should be able to do this while booted from the external HD.

    Any solutions to this problem?

    Thanks,
    Jason
     
  2. jasonkstupski thread starter macrumors newbie

    Joined:
    Aug 4, 2009
    #2
    Solved - I had launched Disk Utility from the internal drive using Spotlight instead of from the External Drive.
     

Share This Page