Problem flashing Sapphire 4890 NE with Zeus in Mac Pro.

Discussion in 'Mac Pro' started by juanm, Aug 6, 2010.

  1. juanm macrumors 65816

    juanm

    Joined:
    May 1, 2006
    Location:
    Fury 161
    #1
    Hi everyone. I already posted this problem in the Golden Guide, but I need an answer fast, in case I have to send the card back.

    After the last attempt (my 4870 arrived dead as the dodo) I got the right (I think) Sapphire 4890 New Edition with Qimonda chips:

    Part Number: 288-1E115-D20SA
    SKU: On the card: 11150-11. Oddly, on the box it's written 11150-11-20R

    I put it in my Mac Pro 1,1 in slot 1 and backed up the Rom in Windows with GPU-Z (.bin file attached)

    With the Mac off, I moved it to slot 2, with my ageing (and dying) X1900XT in slot 1

    I got the ROM number 1, according to the ROM table gathered by Peloche, and attempted to flash it with Zeus, but got the following message:

    "Flashing aborted
    ROM already identical to card firmware.
    Card not compatible with ROM or Zeus."


    Any ideas about what it could be? I tried the Peloche ROM that came in the 01 to 05 pack, as well as another I found elsewhere.
    I thought this card was one of the more widely used, so Zeus is certainly compatible with it, right? Is there anything I have to unlock?

    Also, on a separate issue, how do I have to power the cards during the flashing process? 1 cable to each? Only to the X1900XT?
    I've noticed when I launch the 4890 with only one cable on slot 2, there's a red led turning on under the PCB.

    Thanks for your help
     
  2. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #2
    97% of the time, that error means Zeus does not work with that card.
    go bootcd.
     
  3. juanm thread starter macrumors 65816

    juanm

    Joined:
    May 1, 2006
    Location:
    Fury 161
    #3
    So, I'm happy to report another flashing success using BootCD on a Mac Pro 1,1

    A few difficulties were on the road, though, so I'll list them for those who might need some help:
    I basically followed these instructions: link

    Because now Ultimate Boot CD is in its 5.something version, I had to find the same 4.1.1 version he used. I found it here

    I then proceeded to attempt to flash the card, but it wouldn't recognize it, showing only the X1900XT installed. The problem being that the X1900XT requires a power cable to boot, and the 4890 two power cables to work properly. I solved this powering the card from another PC (cumbersome, but it worked)

    That's about it.

    I now have a problem, though. QE/CI shows as not installed in Zeus, so when I try to install, everything seems to work, but it really doesn't: after the reboot, it still shows as uninstalled in Zeus, and doesn't work. And websites with Flash crash constantly.
     

Share This Page