problem getting bluetooth apt-x codec to work

Discussion in 'Mac Accessories' started by seoulpi, Sep 16, 2012.

  1. seoulpi macrumors newbie

    Joined:
    Sep 16, 2012
    #1
    Hi fellow mac users,

    I recently bought a creative wp-300 bluetooth headphones (comes with Apt-X support) and tried pairing with my macbook pro retina. The process of pairing the device was quite straight-forward and it was completed without much hassle.

    However everytime I performed an option-click on the bluetooth icon, it shows that my active codec for bluetooth audio is SCO instead of Apt-X. There was only one instance after I messed about with connecting and disconnecting the device, I managed to get it worked with Apt-X codec. Sadly, I could not reproduce the same results after trying for the past few days.

    I have done some research on the net and I am sure it is not a bluetooth bandwidth conservation issue as I do not use any other bluetooth device except for this headset. Also, in most of the other cases, people seems to be getting their bluetooth headsets to work with SBC codec rather than SCO. May I ask in terms of sound quality and signal consistency (i.e. frequency of losing beats), how does the SCO codec fare against SBC and Apt-X?

    More importantly, is there any way that I can always get my creative headset to pair and work with Apt-X codec? It is just kind of disappointing that I cannot make use of this technology when it is clearly supported by both devices (mac and headset).

    Regards,
    D
     
  2. seanmclainbrown macrumors newbie

    Joined:
    Dec 12, 2012
    #2
    Enable Apt-x instead of SCO codec

    Hi there, I'm running 10.7.5 ion a mac mini that I use as a media server running Plex as a front end. I bought a pair of Dr. Dre Beats wireless that are Apt-x compliant.

    I had it working for a little while (a month) then apt-x stopped working. I've tried the usual, pause/play, to try to "unstick" the codec and also tried to remove the "initial Bitpool" clause ... And success aptX is know used by iMac. I used the following command: defaults delete com.apple.BluetoothAudioAgent "Apple Initial Bitpool (editable)"

    Which is what worked for me last time. I also had to select/deselect "Don't use as audio device" "Use as audio device" to get it to work last time. Now, that solution doesn't seem to be working for me at all. Now when I try to connect my Beats Wireless, it's in SCO codec mode. But when I don't have the Beats Wireless connected, when I option/click the bluetooth, it shows apt-x as the codec for the Beats Wireless. I'm stumped.

    Anyone have any ideas on how to fix?
     
  3. mac jones macrumors 68040

    Joined:
    Apr 6, 2006
    #3
    A frustrating bug. Best not to even go there until there's a stable fix IMHO.

    I could not make it stick to the codec.

    Until there's a simple switch, this is not ready for prime time.
     
  4. ///KM macrumors member

    Joined:
    Sep 3, 2009
    #4
    I had the same problem with my Sennheiser MM550-X apt-x headphones, until I realized that it was trying to connect to both my MBP and my iPhone at the same time. Once I unpaired them from the iPhone, the MBP reverted from SBC to apt-x codec and stayed that way.
     
  5. phytonix macrumors 6502

    Joined:
    Jan 26, 2006
    #5
    I have Harman Kardon BT. I can get apt-X on my 2010 MBP running Mavericks DP8.

    I cannot get it to connect with AAC or apt-X on my hackintosh, or 2012 iMac 27". I get SBC codec. I am frustrated. But potentially Mavericks will fix this?
     
  6. phytonix macrumors 6502

    Joined:
    Jan 26, 2006
    #6
  7. MDMac macrumors regular

    MDMac

    Joined:
    Dec 2, 2006
    Location:
    Sacramento, CA
    #7
    If none of these recommendations work for you ... Try turning off multipoint functionality on your headphones if the feature is available. Having this enabled forced the SBC codec to be used regardless of the 'force aptx' setting.
     
  8. Franck-AWO macrumors newbie

    Franck-AWO

    Joined:
    Aug 7, 2014
    #8
    I'm running 10.7.5 on a Macmini5,3 (server) and reached to pair it with BT audio transmitter Avantree Saturn Pro in Apt-X mode.

    Just after install, BT connection between Macmini5,3 and Saturn Pro was in SBC mode. LED on Saturn Pro was showing that. And music from Itune Macmini to HiFi home speakers had some little scratches, MP3 played with Vox had less scratches but still have... Those scratches are not when music is played on Creative speakers directly plug in the Macmini.

    Thank's to this thread, I've installed Xcode and Hardward IO Tools for Lion. But using Bluetooth Explorer I didn't found any way to set/force Apt-X mode. May be this version for Lion of BT Explorer does not provide this setting ?-/

    So I just powered off/on Saturn Pro and Macmini5,3 and everything was ok, I mean that LED on Saturn Pro "says Apt-X" and I do not hear scratches any more :)
     
  9. Babylon5 macrumors newbie

    Joined:
    Sep 22, 2014
    #9
    Hi everyone, I am new to this forum but not new to BT 4.0 , APTX and now with Low Latency or LL.
    Here are some info with regards to BT APTX & Low latency (LL)

    1) APTX and LL work independently from BT version, it can be BT2.1 .

    2) APTX and LL again are independent of each other.

    3) For the APTX to work, both the receiver(AKA the sink unit)and the transmitter(AKA as the source unit) must have the APTX codec enabled.
    For example if you are owner of an APTX headset and you are receiving the stream from the BT device on the mobile phone, the mobile phone must be APTX enable in order to enjoy APTX or CD quality music. It applies to othe BT source be it a dongle or built in BT device which can be configure as a SOURCE.
    4) The low latency LL feature which will allow lag free or eliminate lip synch issues when watching a movie. Again both the headset and the transmitter must have this feature. It is of no use if you buy a LL transmitter hub like the Adventree Priva and your headset do not have LL codec because you will not get lip synch free problem when watching video with such wireless headset. At the moment LL headset and mobile phone or PC with LL are as rare as the "blue diamond" so those wanting to enjoy lag free sound from their wireless BT headset is out of luck.
     
  10. MacMojo1 macrumors member

    Joined:
    Mar 22, 2006
    #10
    How do you enable aptx in BT explorer for Yosemite? Xcode 6.1 with hardware io options. I see the dashboard but not sure where to go from there. Thanks in advance.
     

Share This Page