Carrier Problem going from Verizon to T-Mobile on iPad 3

Discussion in 'iPad' started by ycoidi2000, Nov 14, 2013.

  1. ycoidi2000 macrumors member

    Joined:
    Jul 27, 2008
    #1
    After having successfully gone from Verizon to T-Mobile on my iPad mini, I thought I'd get a micro SIM and go for the free 200 MB on my iPad 3. After I shut it down, put the new SIM in, and then re-provisioned, all seemed to go well (I see T-Mobile up in the upper-left-hand corner).

    What I'm not seeing under cellular data is the "View Account" button. Instead, I have the "Set Up Personal Hotspot" button, which clearly isn't what I want. I've tried resetting all network settings, but that didn't seem to work, either.

    So...what have I done wrong? I'm feeling pretty stupid right now. :(

    Thanks!
     
  2. PLin macrumors 6502

    Joined:
    Oct 9, 2003
    #2
    On my AT&T iPad 3, I also couldn't sign up under Cellular Data. It's not exactly intuitive, but you have to open Safari, which should redirect you to a T-Mobile sign up page.
     
  3. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #3
    If you turn wifi off, reprovision, turn off then on, then open safari & go to a site does it redirect to TMob?
     
  4. ycoidi2000 thread starter macrumors member

    Joined:
    Jul 27, 2008
    #4
    I tried and got:

    "Safari could not open the page because the server stopped responding."
     
  5. herdnerfer macrumors 6502

    Joined:
    Feb 12, 2011
    Location:
    Saint louis, MO
    #5
    iPad 3rd Gen had 2 different models of LTE. One for ATT & one for Verizon. It may not be possible to use on T-Mobile.
     
  6. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #6
    Worked for me on my Verizon ipad3

    Tmobile's servers can be wonky, also it took a little bit of it just sitting with wifi off to update carrier settings, then going to a web page allowed me to sign up for the free 200mb. I may have had to use chrome browser instead of safari, I don't recall offhand.
     
  7. rui no onna macrumors 601

    rui no onna

    Joined:
    Oct 25, 2013
    #7
    The View Account thing didn't show up on my Verizon iPad, either but with wi-fi off, I got redirected to http://mim.t-mobile.com/ where I was able to set up my account. Right now, I think T-Mobile's just experiencing an unusually high volume of sign-ups so their server might act wonky on occasion.
     
  8. ycoidi2000 thread starter macrumors member

    Joined:
    Jul 27, 2008
    #8
    Thanks for all the help. Late last night I was able to get it to work!
     
  9. osofast240sx macrumors 68030

    osofast240sx

    Joined:
    Mar 25, 2011
    #9
    How?
     
  10. ycoidi2000 thread starter macrumors member

    Joined:
    Jul 27, 2008
    #10
    I tried later in the evening to refresh Safari and the t-mobile site came up (with wifi turned off).
     

Share This Page