Problem importing CD into iTunes

Discussion in 'Mac Apps and Mac App Store' started by wyoprof, Jan 21, 2004.

  1. wyoprof macrumors newbie

    Jan 21, 2004
    I've just upgraded from an older G4 powerbook to a new one, and for some reason iTunes now won't import a CD. I get an error message saying "Error occurred while converting the file 'Coma Girl'. You do not have enough access privileges for this operation." I've tried changing permissions, both on the command line with "chmod" and "chown", and using the "Get Info" option in the Finder, to no avail. (I seem unable to change the permissions, even using sudo and a valid root password.) This is keeping me from putting Joe Strummer's great final album on my iPod! :( Any help would be greatly appreciated.
  2. unregbaron macrumors regular

    Oct 20, 2002
    perhaps this is a side issue but i found interesting problems to do with AAC being the default on a new PB which seemed to mean tracks weren't read on a 1st gen ipod used to mp3 -
  3. yamadataro macrumors 6502

    I believe that 1st gen ipod users just need to upgrade the firmware to make it play AAC. I used to have the very first 5GB model and played AAC with the lastest software update.
  4. wyoprof thread starter macrumors newbie

    Jan 21, 2004
    Problem solved

    I've found the problem -- it was an ownership/permission problem on the destination iTunes music folder. I had been changing permissions on the CD, not the destination folder (duh).
  5. absurdio macrumors 6502

    Aug 25, 2003
    RI, Chi, and/or NY.
    So this isn't the SAME problem, but it does fit under the same topic, I believe.

    For the most part, iTunes imports my cds fine. I've come across only one cd that i'm having trouble with...and i don't know what's going on.

    It imports a 1:47 of the first song, 0:07 of the second song...and just stops importing each song for no reason. Each of those first two songs is over six minutes. But all of the tracks are ended prematurely, and I don't know why. The disc isn't scratched, and it plays fine in my computer. The artist isn't major enough that I'd suspect the CD of having copyright protection active on it. When i try to copy the files manually to my desktop, i get (after STARTING to copy the song fine) "The operation cannot be completed because some data cannot be read or written." ....why the hell not? this should be a pretty basic operation. Anyone else run into this ever?

Share This Page