Problem in 2011 MacBook Pro graphics

Discussion in 'Mac Basics and Help' started by macabrix, Dec 3, 2013.

  1. macabrix macrumors newbie

    Joined:
    Dec 3, 2013
    #1
    Hi, it's my first post here and I really need some technical help from someone with a similar machine.

    I own a MacBook Pro (15-inch, early 2011) and recently decided to reinstall Guild Wars 2 on Windows 8.1 bootcamp. However, I unexpectingly got terrible FPS (7-8 on Lion's Arch!) with latest modded 13.11 catalyst ATI drivers, I used to run the game at a solid 15-25 FPS on the same mac some months ago...

    First I tought it was a drivers problem, but even with the old ones I got the same problem... then I tried to run the OSX client, I knew it wasn't perfect last time I tried it but it ran the graphics smoothly from what I remember... still got the same terrible FPS. I opened a ticket to GW2 support and after a few diagnostics and a GPU-z screenshot they responded that the speed the GPU (PCIe) is running at X1 speeds instead of X16... is it supposed to run at 16x? Has something fried on my machine?

    I've attached the GPU-z report... guess the speed is the same when booting OSX mavericks since the OSX client was still slow.


    Thanks in advance
     

    Attached Files:

  2. macabrix thread starter macrumors newbie

    Joined:
    Dec 3, 2013
    #2
    Anyone? :(

    I just need to check the normal PCIe speed that a non-damaged macbook pro from early 2011 to see if I need to send it to repair.

    I'm sure there are similar apps to GPU-z for OSX to check it out
     
  3. tinix macrumors newbie

    Joined:
    Jun 14, 2013
    #3
    AMD site says it is supposed to use x16 bus so probably the GPU or the PCIe bus is dying.
     

Share This Page