Problem in camera app

Discussion in 'iOS Programming' started by iphonejudy, Jul 1, 2009.

  1. iphonejudy macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #1
    I wrote the below code for "Use Photo" button of the camera

    Code:
    - (void)imagePickerController:(UIImagePickerController *)picker didFinishPickingImage:(UIImage *)img editingInfo:(NSDictionary *)editInfo {
    		
    	UIImageWriteToSavedPhotosAlbum(img, nil, nil, nil);
    	
    	[[picker parentViewController] dismissModalViewControllerAnimated:YES];
    
    //To show the TestUpload view
    	Testupload *vController = [[ Testupload  alloc] 
    							   initWithNibName:@"Testupload" bundle:[NSBundle mainBundle]];
    	
    	//set the view.
    	self.testupload = vController;
    	
    	
    	
    	//release the view controller.
    	[vController release];
    	
    	//Add the view as a sub view to the window.
    	//Here we are asking the view controller to get its view and add it as a subview to the window.
    	[self.view.window  addSubview:[testupload view]];
    	// Override point for customization after app launch	
        [window makeKeyAndVisible];
    	
    	
    	
    }
    
    
    


    When i click the "Use Photo" button the capture image is stored in "Photos",

    It shows the Testupload screen.It contains two buttons

    The buttons are not activated in the test upload screen?

    Can anyone tell me the solution?
     
  2. iphonejudy thread starter macrumors 6502

    iphonejudy

    Joined:
    Sep 12, 2008
    #2
    I solved by set userInteractionEnabled option.
     

Share This Page