Problem installing command line tools in 10.9 (error: not available from server)

Discussion in 'Mac Programming' started by gregor.hoch, Oct 24, 2013.

  1. gregor.hoch macrumors member

    Joined:
    Apr 5, 2011
    #1
    Hi,
    I have been trying to install the command line tools for 10.9 since yesterday but always run into the same error message. After running 'xcode-select --install' in the terminal and clicking install, I the installation starts but stops with the error "Can't install the software because it is not currently available from the Software Update server" after a moment.

    XCode is installed and updated to 5.0.1

    Any ideas? Thanks!
     
  2. jeffzoom91 macrumors regular

    jeffzoom91

    Joined:
    Jul 25, 2005
    Location:
    Florida
    #2
    It's not in the list anymore.

    Xcode Command Line tools now come with Xcode.

    Easy test: On a fresh machine, open a terminal window and type 'git'. It asks you if you want to get Xcode. Then go install Xcode...now type 'git'...it works!

    It's not a separate install anymore! Yay!

    According to the terminal error though I think you can still install it separate to Xcode itself however.
     
  3. gregor.hoch thread starter macrumors member

    Joined:
    Apr 5, 2011
    #3
    Thanks for your suggestions! I have Xcode installed but the command line tools are not there. Rcpp complains that there is no compiler and when I type 'xcode-select --install', I am ask whether I want to install the command line tools. After clicking 'install', I get the error. So it's doesn't solve my problem...
     
  4. omphaloskeptic macrumors newbie

    Joined:
    Oct 27, 2013
    #4
    same issue

    Same problem -- this happened when I deleted xcrun in an attempt to start over with a fresh copy of the command line utils after failing to build a Ruby gem due to a xcrun dependency. (OK, probably shouldn't have done that.) I'm getting the same error message, even though I've just reinstalled the latest XCode 5.0.1. Not sure how else to get a copy of xcrun, unless someone wants to post it here. The only thing I can think of now is to start over with a clean install of Mavericks, which I'd rather not do if I don't have to. Help!
     
  5. eagleton macrumors newbie

    Joined:
    Oct 27, 2013
    #5
  6. AlwaysLearning1 macrumors newbie

    Joined:
    Mar 17, 2014
    #6
    As jeffzoom91 said, the XCode Command Line Tools come with XCode 5.0+.

    Despite this Xcode reported the wrong path at the console:
    Code:
    $ xcode-select -p
    /Applications/Xcode.app/Contents/Developer
    You can switch the path, though:
    Code:
    $ sudo xcode-select --switch /Library/Developer/CommandLineTools
    Password:
    After which you get the correct path:
    Code:
    $ xcode-select -p
    /Library/Developer/CommandLineTools
    This was enough to make macports happy for something else I was trying to install.
     

Share This Page