Problem installing Snow Leopard

Discussion in 'macOS' started by CoolPuppy, Jul 1, 2009.

  1. CoolPuppy macrumors newbie

    Joined:
    Apr 5, 2006
    #1
    (I tried this on another thread, but it looks dormant, so re-posting into a new thread)

    Whenever I boot up the SL install disk (either plugged in via USB drive or remote disc from my iMac), I select English as my language, "Continue" on the welcome screen, and when I get to the portion where I have to choose a disk to install onto, my MBA's hard drive has a yellow triangle on it and a caption underneath that says "Mac OS X Cannot Start Up From This Disk".

    I've used Disk Utility to Verify and Repair, but still get the same result.

    My MacBook Air is a 2nd generation machine, 120G hard drive (45G free), and MS Office 2008 installed. Other than that (and all my music and files), it's exactly as it came from Apple when I ordered it.

    I was able to install fine on my MBP and iMac.

    Any help would be appreciated.

    Thanks!
     
  2. Wowzera macrumors 6502a

    Joined:
    Oct 14, 2008
    Location:
    Brazil
    #2
    Did you perform a CRC check? Your image looks to be corrupt.
     
  3. JGruber macrumors 6502

    Joined:
    Feb 13, 2006
  4. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #4
    Wrong. Multiple partitions means ANY OS with ANY OS.
     
  5. JGruber macrumors 6502

    Joined:
    Feb 13, 2006
    #5
    I know this can be done in Windows, but I have never done it on a Mac.

    I stand corrected then. Sounds like he needs to create a separate partition then.
     
  6. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #6
    Oh, hasn't he? :eek:

    Yeah, OP, you need another partition. :D
     
  7. JGruber macrumors 6502

    Joined:
    Feb 13, 2006
    #7
    Based on what he said, it sounds like he just has the 45GB free, but no separate partition. If that is the case, you do in fact need another partition. 20+ GB should be good for what you need.
     
  8. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
  9. CoolPuppy thread starter macrumors newbie

    Joined:
    Apr 5, 2006
    #9
    I'd like to install Snow Leopard on top of my Leopard install. That's what I did on my iMac and MBP. I'm curious what's going on with my MacBook Air.
     
  10. CoolPuppy thread starter macrumors newbie

    Joined:
    Apr 5, 2006
    #10
    Yes, I performed a CRC check and everything is fine.

    And, yes, the partition map is GUID.
     
  11. store2000 macrumors newbie

    Joined:
    Aug 26, 2009
    #11
    Any luck? I have a pretty similar/exact issue.

    Hi guys,

    I have an early 2009 Aluminium Macbook on 10.5.8. When I was trying to upgrade it to 10.6, I'm unable to select my Leopard partition. I get the following error when I select my current Leopard partition:

    <Booted into the installer>
    Mac OS X cannot start up from this disk

    <Running the Installer from within Leopard>
    Mac OS X cannot be installed on "Leopard", because this disk cannot be used to start up your computer.

    I can easily dual boot into Windows 7 & Leopard and the details of my disk are below. I've also tried with and without rEFIt, no luck - same message. I've also tried choosing the Leopard partition from the Startup Disk system preferences panel - again, no luck.

    Does any one know what the fix to this may be? This is a straight-up legit Mac ... so I would have thought it would work right out of the box!

    Thanks!

    Output of fdisk
    ===============
    Code:
    Disk: /dev/disk0    geometry: 30401/255/63 [488397168 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
     2: AF 1023 254  63 - 1023 254  63 [    409640 -  368635540] HFS+       
    *3: 07 1023 254  63 - 1023 254  63 [ 369045180 -  119346885] HPFS/QNX/AUX
     4: 00    0   0   0 -    0   0   0 [         0 -          0] unused     
    
    Output of gptinfo
    =================
    Code:
    Warning: /dev/disk0 opened read-only
    
    Current GPT partition table:
     #      Start LBA      End LBA  Type
     1             40       409639  EFI System (FAT)
     2         409640    369045179  Mac OS X HFS+
     3      369045180    488392064  Basic Data
    
    Current MBR partition table:
     # A    Start LBA      End LBA  Type
     1              1       409639  ee  EFI Protective
     2         409640    369045179  af  Mac OS X HFS+
     3 *    369045180    488392064  07  NTFS/HPFS
    
    Status: Tables are synchronized, no need to sync.
    
     
  12. jbencic macrumors newbie

    Joined:
    Aug 28, 2009
    #13
    I to am getting this problem attempting to install Snow Leopard

    i have tried both booting from dvd and through finder

    this might have something to do with rEFIt as i am triple booting linux, mac and windows

    i have disabled rEFIt and reblessed the main disk and still no go

    any ideas?
     
  13. store2000 macrumors newbie

    Joined:
    Aug 26, 2009
    #14
    No actual fixes, but some ideas and additional attempts on this problem at
    http://forums.mactalk.com.au/46/72235-snow-leopard-wont-install-9month-old-macbook.html
    and
    http://www.insanelymac.com/forum/index.php?showtopic=181955
     
  14. Richard1028 macrumors 68000

    Joined:
    Jan 8, 2009
    #15
    Uh... how about calling Apple? (Now that SL is officially released). You did buy it didn't you?
     
  15. okachobi macrumors newbie

    Joined:
    Oct 30, 2007
    #16
    iPartition???

    I'm having the same problem and can't try the fix I read about (which is to resize the HFS+ partition using diskutil). DiskUtil tells me that "MediaKit reports no such partition", even though the disk uses a GPT.

    So I did some digging and discovered that iPartition (a 3rd party partitioning tool) shows that my HFS+ partition is not "bootable". When I mouse over that it indicates that 128M must be left after the partition to make it bootable. And it does give the option to check that box once I reduce the size of the partition to make space available. I suspect that those who have succeeded with DiskUtil did so because diskutil automatically made this adjustment to make the partition bootable.

    BUT, iPartition demo (the trial version) does not write the changes :-( And I don't do enough partitioning to justify a $50 utility just to see if it fixes my problem. I suspect it will...but I have no way to test it. DiskUtil would probably fix the issue as well if it let me resize the partition without the MediaKit error message....but again, I have no idea how to get rid of that message.

    I have 4 partitions and am using RefIT to boot into Ubuntu. I'm wondering if the resize fails because there are already 4 partitions. I've thought about deleting the linux swap partition and seeing what happens. I've read somewhere that there is something magic about the 4 partition limit...

    I just wish iPartition had a real trial...
     

Share This Page