Problem Installing Win 7 on Intel SSD Ver. 1

Discussion in 'Windows, Linux & Others on the Mac' started by Ozamandiz, Jan 21, 2010.

  1. Ozamandiz macrumors newbie

    Joined:
    Oct 4, 2005
    #1
    I'm having an unusual problem trying to install Win 7 or even XP on a Unibody Mac Book, purchased Feb. 2009. It did work in the past with the original disk drive. I installed both XP and Win 7 and both worked but later removed the Windows partition.

    A few months ago I removed the original drive an installed an Intel 160GB SSD MLC Version 1 and installed Snow Leo without any problem. My intention was to eventually install a production version of Win 7 when Apple make the official drivers available.

    Prior to trying to install Win 7 the Mac Book was updated with all the latest software including the new EFI.

    Book Camp was used to parition the Intel SSD and a 64-bit Win 7 DVD was inserted to begin the installation but it could not find a disk drive! At first I thought Win 7 lacked the proper 64-bit driver so I tried againw with a 32-bit version but again it would not recognize the Intel SSD.

    So as an experiment, I tried loading a tried and true new install CD of XP PRO/SP3 and again had the same problem--no disk drive could be found to load Windows.

    I suspect there is a conflict between the Mac Book EFI and the Intel SSD but only for Windows since Snow Leo loaded and has been working perfectly with the Intel drive.

    Has anyone else had this experience? Or had it with anothe brand of SSD?

    Thanks for any and all help!

    Paul
     
  2. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #2
  3. whit8725 macrumors newbie

    Joined:
    Jan 21, 2010
    #4
    Let me know if you have an X-18 Intel SSD? I might be able to help. I had the same problem with my 80 gig X-18 and have fixed it with a firmware upgrade.
     
  4. Ozamandiz thread starter macrumors newbie

    Joined:
    Oct 4, 2005
    #5
    Thanks, it worked perfectly and Win 7 now finds the Intel SSD!

    I could kick myself in the a** for not trying this earlier. I had already downloade the firmware patch and applied it to an 80GB retail version of the Intel SSD which was installed in a netbook.

    The version in the MAC was an older 160GB OEM version of the Intel SSD.

    Thanks again!

    Paul
     

Share This Page