All iPads Problem: iPad and getting a https connection through a proxy server.

Discussion in 'iPad' started by Ollie Cromwell, Jun 7, 2010.

  1. Ollie Cromwell macrumors member

    Ollie Cromwell

    Oct 29, 2006
    I have a proxy server that I need to get through at work, my Mac has no trouble as in the network control panel I can specify a port for each specific type of traffic eg http, https etc. However I cant specify that level of detail in the network connections in my iPad as it only asks for the proxy server address and port once. is there any way to specify the proxy server for the https connection in the ipad OS?

    It just means that loads of apps that use that port will not connect at the moment.

  2. imagespace macrumors newbie

    Jun 9, 2010
    Similar problem

    I am very puzzled by this though. My iPhone connects to the wireless network at work and is set up exactly the same, using the same proxy settings. The iPhone, however, does not show the same issues.

    My iPad, whilst it will allow me access to the internet. If I try to login to any sites, I get a proxy (HTTPS) problem and can't log in. This also happens with apps that log into web sites when opened.

    So why does the iPhone work OK, yet the iPad doesn't??

  3. peranet macrumors newbie

    Jun 14, 2010
    I have the same problem. If you find a solution please post it.

    Thank you very much,
  4. duluxanon macrumors newbie

    Jun 27, 2010
    i was able to resolve this on my new ipad (just got this morning yay!).

    Anyway enter your proxy port, then when finished tap on theyour ip address settings up above... then click the home button...

    for some reason if you dont click off the port frame it doesnt save it... if you click on the ip address or dns or router info above it then leave the page it works fine...
  5. jewelrywang macrumors newbie

    Sep 8, 2010
    still cannot fulfill HTTPS connection through wireless+proxy.

    This doesn't work for me. I tried several valid proxy servers available in my office but all failed. The setting is definitely saved. I can navigate to any websites except those requiring HTTPS. And as mentioned above, some apps like youtube and twitter can't work neither.

  6. stix macrumors member

    Aug 2, 2010
    Helvetic Confederation
    I had a very similar problem not being able to connect to an activesync server (which uses https over port 443 I think) for a mail account. Turned out not to be anything to do with the iPad, but a wrong setting on the router. Try using a different router if you can. In my case (Netgear WNDR3700) the default mac address settings were wrong. Worth a try....
  7. cashxx macrumors member

    Sep 14, 2010
    Workaround found?

    Anyone having this problem still?? Having the issue here! Wondering if anyone has found a workaround?
  8. tekchic macrumors 65816


    Apr 19, 2010
    Phoenix, AZ
    It has to do with the iPad's iOS version. 3.2.2 iPad OS doesn't support HTTPS, which is why if you have an iPhone on 4.0+, you can access it but not on iPad.

    The 4.2 OS that is forthcoming is supposed to have HTTPS support. Let's hope so.
  9. mikeerhymes, Nov 24, 2010
    Last edited: Nov 24, 2010

    mikeerhymes macrumors newbie

    Nov 24, 2010
    has anyone got any further with this yet?
    i have just put on the IOS4.2 and still no https proxy setting!!!:mad:

    any fresh ideas????
  10. ASRCH macrumors newbie

    Nov 6, 2012

    i have problem with protocol https in IPad .

Share This Page