Problem: MacBook Pro and iSight camera stops working after resume from standby

Discussion in 'MacBook Pro' started by burratha, Mar 23, 2009.

  1. burratha macrumors newbie

    Joined:
    Nov 21, 2007
    #1
    Hi all.

    As per my topic, I have a 1 yr old MacBook Pro with built-in iSight camera. Recently I have noticed a problem where my iSight camera stops being seen by the system following a resume from sleep/standby.

    I am running 10.5.6 fully updated at the time of writing.

    I noticed the problem in iChat AV where the icon next to my name changed from a video camera to the telephone icon. Checking the options, shows "there is no camera attached to this computer". Photo Booth, Skype, and similar apps all show no camera attached.

    System profiler has also lost connectivity with the device, with no relevant entry under USB.

    I reset the PRAM, and also SMC and although that makes the camera start working again, it loses communication with it right after a sleep/resume.

    I have also created new profiles and they are also affected by the non-connectivity until I reset the SMC/PRAM.

    Does anyone have any ideas please?

    My Apple Care ran out in early March :(
     
  2. ekoe macrumors member

    Joined:
    Mar 7, 2008
    Location:
    London, UK
    #2
    Try resetting the PRAM, or 'reset all' in open firmware.
     
  3. ekoe macrumors member

    Joined:
    Mar 7, 2008
    Location:
    London, UK
    #3
  4. ekoe macrumors member

    Joined:
    Mar 7, 2008
    Location:
    London, UK
    #4
  5. burratha thread starter macrumors newbie

    Joined:
    Nov 21, 2007
    #5
    Thanks all so far.

    PRAM reset, as well as SMC have no effect now. I've taken the back of the screen off to check physical connections and they all appear to be fine.

    Looks like I'll have to live with it, unless it resurrects itself?
     
  6. MistaBungle macrumors 6502a

    MistaBungle

    Joined:
    Apr 3, 2005
    #6
    My girlfriend had this problem with her MacBook, and I can only assume it came from installing Office '08. After a reboot and another install of Office '08 it was fine and everything worked.
     
  7. burratha thread starter macrumors newbie

    Joined:
    Nov 21, 2007
    #7
    Ok... slight update for everyone.

    I (finally) managed to get the thing working again. I'm certain its a software issue as the iSight showed up ok in the System Profiler when I booted from a Leopard install disk.

    When rebooting back into Leopard, the camera worked fine ..... UNTIL I closed the lid and we're now back to square one.

    One thing of note; I tried to repair Disk permissions, but there seem to be some permissions that won't repair no matter how many times I run the application. I've pasted the log below, I wondered if anyone could diagnose an error from it?

    Code:
    Repairing permissions for “Macintosh HD”
    	Reading permissions database.
    	Reading the permissions database can take several minutes.
    
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/DVD.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/FRSettings.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/FRSources.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/Movies.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/Music.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/Photos.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/Podcasts.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/CoreServices/Front Row.app/Contents/PlugIns/TV.frappliance/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/BackRow.framework/Versions/A/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "Applications/iTunes.app/Contents/CodeResources", should be -rw-rw-r-- , they are lrw-rw-r-- .
    Permissions differ on "Applications/iTunes.app/Contents/Frameworks/InternetUtilities.bundle/Contents/CodeResources", should be -rw-rw-r-- , they are lrw-rw-r-- .
    Permissions differ on "Applications/iTunes.app/Contents/Resources/iTunesHelper.app/Contents/CodeResources", should be -rw-rw-r-- , they are lrw-rw-r-- .
    Warning: SUID file "System/Library/Filesystems/AppleShare/afpLoad" has been modified and will not be repaired.
    Warning: SUID file "usr/bin/setregion" has been modified and will not be repaired.
    Permissions differ on "System/Library/CoreServices/RawCamera.bundle/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Warning: SUID file "System/Library/PrivateFrameworks/Install.framework/Versions/A/Resources/runner" has been modified and will not be repaired.
    Warning: SUID file "System/Library/Printers/IOMs/LPRIOM.plugin/Contents/MacOS/LPRIOMHelper" has been modified and will not be repaired.
    Group differs on "private/etc/cups", should be 0, group is 26.
    Permissions differ on "private/var/spool/cups/cache/rss", should be drwxr-xr-x , they are drwxrwxr-x .
    Permissions differ on "System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/BlackAndWhiteEffect.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/CubeTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/DissolveTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/DropletTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/FadeThroughBlackTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/FlipTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/MosaicFlipTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/MosaicFlipTransitionSmall.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/PageFlipTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/PushTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/RevealTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/SepiaEffect.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/TwirlTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "System/Library/PrivateFrameworks/iPhotoAccess.framework/Versions/A/Resources/Plugins/WipeTransition.IAPlugin/Contents/CodeResources", should be -rw-r--r-- , they are lrw-r--r-- .
    Permissions differ on "Developer/Examples/JavaWebObjects/DataBaseSetUp/dbdump.sh", should be -rw-rw-r-- , they are -rwxrwxr-x .
    Permissions differ on "Developer/Examples/JavaWebObjects/DatabaseSetup/dbdump.sh", should be -rwxrwxr-x , they are -rw-rw-r-- .
    
    Permissions repair complete
    
     
  8. burratha thread starter macrumors newbie

    Joined:
    Nov 21, 2007
    #8
    This problem is still in charge of my MBP not working as it should :(

    Does anyone have any suggestions before I use the excuse to buy and install a new HDD when I reinstall OSX?

    TIA
     
  9. ViciousShadow21 macrumors 68020

    ViciousShadow21

    Joined:
    Mar 11, 2009
    Location:
    To your left or right
    #9
    i cant think of anything. as you said the permissions are the problem so its archive and install time.
     
  10. burratha thread starter macrumors newbie

    Joined:
    Nov 21, 2007
    #10
    Brand new install, and the camera came back for a short while before it disappeared again.

    Looks like I'll have to make do without.

    Thanks for the input, all.
     
  11. ViciousShadow21 macrumors 68020

    ViciousShadow21

    Joined:
    Mar 11, 2009
    Location:
    To your left or right
    #11
    why dont you take to apple and have them replace it?
     
  12. burratha thread starter macrumors newbie

    Joined:
    Nov 21, 2007
    #12
    Its 13 months old and I didn't get the extended Applecare in time.

    Also, you (apparently) can't buy the camera arrangement separately, its shipped with the screen as a complete item. At $900+ for a unit I think I can live without it.

    Shame really, as its tarnished my own perception of Apple kit being quality :(
     
  13. ViciousShadow21 macrumors 68020

    ViciousShadow21

    Joined:
    Mar 11, 2009
    Location:
    To your left or right
    #13
    hmm thats too bad.
     
  14. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #14
    What happens when you try to run the Apple Hardware Test?
     
  15. burratha thread starter macrumors newbie

    Joined:
    Nov 21, 2007
    #15
    I'll try that tonight, I don't have the restore disc here with me at the moment
     

Share This Page