Problem opening apps after blackra1n jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by dmo199, Oct 15, 2009.

  1. dmo199 macrumors newbie

    Joined:
    Oct 15, 2009
    #1
    I took the dive last night and upgraded my iPhone 3G to 3.1.2 and jailbroke it using blackra1n, other than forgetting to start it with Administrator privilledges it all went perfectly! :)

    I installed both Cydia and Rock and have installed all the packages below... and had no problems with them or the built in apps but this morning I tried some of the apps from the app store, facebook, air mouse, quad camera... they all look like they are loading for a couple of seconds and then just close :(

    I am happy to restore back to factory default and try again but dont want to if I dont have to. Has anyone else had this problem and found a fix?
     
  2. PaulAshcroft25 macrumors member

    Joined:
    Oct 2, 2009
    #2
    I cant answer your question, but when you restore do you just restore using Itunes and a clean 3.1.2 or do you have to do a custom IPSW? Thanks.
     
  3. dmo199 thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #3
    Oops... forgot the packages!
    APR (/usr/lib)
    APT 0.7 (apt-key)
    APT 0.7 Strict (lib)
    Base Structure
    BigBoss's Source
    BookReader
    Bourne-Again SHell
    bzip2
    Core Utillties
    Core Utilities (/bin)
    Cycorder
    Cydia Community Source
    Cydia Installer
    Darwin Tools
    Debian Packager
    Diff Utilities
    Find Utilities
    Five Icon Dock
    GNU Privacy Guard
    grep
    gzip
    IBox Carbon
    iPhone Firmeware
    iSpazo
    libxml2 library
    LZMA Utils
    Mobile Substrate
    MobileTerminal
    ModMyi.com
    New Curses
    Notifier Widget
    OpenSHH
    OpenSSL
    Orbz
    PAM (Apple)
    PAM Modules
    pcre
    PrefereneceLoader
    Profile Directory
    quake4iphone
    readline
    ReflectiveDock
    Rock Extensions
    RockApp
    Saurik's Source
    sed
    shell-cmds
    SQLite 3.x Library
    StatusNotifier
    Ste's Source
    system-cmds
    Tape Archive
    WebViewController
    WinterBoard
    ZodTTD's Source

    Anything dodgy in there?
     
  4. dmo199 thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #4
    I havent tried it yet... I found where it downloaded the 3.1.2 update to so was going to try and restore to that.
     
  5. nickrinaldi macrumors regular

    Joined:
    Jul 21, 2009
    #5
    fixed something similar

    i had a similar problem yesterday on my iphone which is jailbroken with the blackra1n tool. I was using aim and i exited the app then decided i forgot to type something to someone and tried to start the app right back up immediatly.

    after i did that the app wouldnt load. then every app store app on my phone, tweetie facebook google etc.. all would open and close. i thought i was screwed. but then i figured i'd just try deleting aim since that was the app that i was in when the problem started. that did not work just deleting it cause the other apps still wouldnt open. so i redownloaded aim. and then boom everything worked again. i setup my aim settings again and my phone is fine again. so maybe if you remember which app you last used succesfully you can try deleting and reinstalling it.
     
  6. dmo199 thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #6
    Thanks for answering so quickly :), sounds like might do the trick... if only I could remember the last app I opened :confused:

    Might have to be trial and error, I'll let you know if I find it
     
  7. WRXface macrumors regular

    Joined:
    Aug 6, 2008
    #7
    I'm having the same problem but i downloaded everything you listed.
     
  8. dmo199 thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #8
    Solution!

    Thanks to nickrinaldi! I couldnt remember what app I used last, so instead I just installed a random app from the app store. Everything worked fine after that and I didnt have to unistall anything :D
     
  9. vtmikevt macrumors regular

    Joined:
    Oct 11, 2007
    #9
    I've tried this and it didn't work for me. I even tried restoring to a backup that was created after the jailbreak and that didn't work. Ended up having to restore to a clean 3.1.2 and jailbreak again.
     
  10. KSUWizard macrumors member

    Joined:
    Dec 19, 2008
    Location:
    Manhattan, KS
    #10
    It sounds almost like a memory problem. When my iphone has no memory to run apps, usually because i have 3-4 pages of safari open, apps just have no memory so they open then close quickly. Get a memory checker/clearer and see if that helps. It's atleast worth a shot!
     
  11. vtmikevt macrumors regular

    Joined:
    Oct 11, 2007
    #11
    that would seem like a possible problem except it ONLY occurred for 3rd party apps from the Apple App Store (not native apps or Cydia apps).
     

Share This Page