Problem printing in Leopard on Samsung ML2010

Discussion in 'Mac Accessories' started by Supaklaw, Dec 9, 2008.

  1. Supaklaw macrumors regular

    Joined:
    Feb 8, 2008
    Location:
    NYC
    #1
    I've had this laser printer for a while and am happy with it, but since switching to Leopard it doesn't print. It worked fine on my iMac in 10.4, and currently works fine in Bootcamp using XP 64-bit on my 2008 Mac Pro. In all cases I'm using USB connections. Installed latest drivers, blah blah, but print utility keeps putting print on pause, and if I hit resume... it hangs, then kicks back to pause mode. And file is always listed as "Stopped".

    Clearly a software driver issue but I think these Samsung drivers are from 2005... but not sure why it would make that much difference seeing it's a USB plug and play device, and it works on the PC side without a hitch. Do I need to use Gutenprint or something?
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    I don't have one of those, so I'm not sure what you "need" to do...
    I suggest you experiment with the Samsung-GDI driver set from here:
    http://www.linuxfoundation.org/en/OpenPrinting/macosx

    PS- I wouldn't/couldn't respond to your post on Apple Discussions because that thread was so confusing - every poster was talking about a different situation. Including you :)
     
  3. Supaklaw thread starter macrumors regular

    Joined:
    Feb 8, 2008
    Location:
    NYC
    #3
    Hehe I know sorry. Half were having issues network printing, nothing to do with the GDI stuff. I tried the Gutenprint drivers from sourceforge and nothing. Tried installing the samsung drivers off the leopard disk, before and after using the direct download Samsung site's "leopard" drivers and still nothing. It's got to be a GDI language issue as someone suggested so I'll try the driver set you recommend tonight, thanks man. :)
     
  4. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #4
    I put leopard on my Mac over a year ago and installed my Samsung ML2010 and it works fine...I don't remember having had to do anything special to get it to be recognized, and it's printed fine ever since. Not a lot of help, but just lets you know that it can work.
     
  5. millerj123 macrumors 6502a

    Joined:
    Mar 6, 2008
    #5
    I put it on mine almost a year ago. I had to use the Gutenprint drivers, and it didn't put the Samsung in the same alphabetic order as the original drivers. I kept looking in the "S" range, and it's in "M" for ML-2010.

    After that, it works great.
     
  6. Supaklaw thread starter macrumors regular

    Joined:
    Feb 8, 2008
    Location:
    NYC
    #6
    Well tried the open print drivers, still nothing. I'd probably be better served by reinstalling a clean Leopard copy, there's probably something conflicting... but no idea what the issue is... good to hear the ML2010 is working on some copies though, I'll figure it out.
     
  7. CompuRob macrumors newbie

    Joined:
    Aug 29, 2008
    Location:
    Virginia
    #7
    My Samsung ML-2010 works under Snow Leopard on my MBPro.

    My wife has a newer MBPro but is still running Leopard. The driver from Samsung's site just won't install on her machine.

    Is it a driver issue or a Leopard Issue? Think a simple upgrade to Snow Leopard will fix it?

    FRUS-TRA-TING!
     
  8. izibo macrumors 6502

    Joined:
    Oct 6, 2004
    #8
    Yes
     
  9. TXTahoeHo macrumors newbie

    Joined:
    Mar 22, 2010
    #9
    Problem printing in Leopard on Samsung ML2010

    I experienced the same problem trying to run the ML 2010 on Leopard 10.5.8. Spent countless hours on tech support calls with Apple & Samsung. Completely re-installed my start up disk and upgraded all applications and tried to re-install "updated" driver from Samsung support website...STILL NO LUCK!

    Anyone have any new suggestions?? Thanks!
     
  10. gabe130 macrumors newbie

    Joined:
    Aug 15, 2010
    #10
    Problem printing in Leopard on Samsung ML-2010

    SOLUTION: Switch the printer driver to the "ML-1630 Series" driver which is already included with the OS, and is compatible with the Samsung ML-2010 printer.

    I had the exact same problem printing to the Samsung ML-2010 under OS 10.5. It used to print fine on my PowerBook G4 with OS 10.4, but when I switched to a MacBook Pro running OS 10.5, it just would not print. Every time I would send a job to the printer it would display the status as "Stopped".

    After searching for answers with no luck, I decided to try using print drivers for other Samsung models that were already included with OS 10.5. After trying several drivers, I finally found one the WORKED! It's the driver called "ML-1630 Series". Basically go into your printer "Options & Supplies" and click on the "Drivers" tab, and switch your driver to the "ML-1630 Series" driver which is already included with your OS.

    Let me know if this works for you.
     
  11. Moshe Feder macrumors newbie

    Joined:
    Aug 19, 2010
    #11
    It did!

    Take a bow Gabe130, you just allowed me to help my girlfriend print out her boarding passes for a major trip.

    Gosh, but printer issues are sure 'logical', eh? Who'd have expected that loading the 'wrong' driver would solve such a persistent and frustrating problem. Many thanks for sharing this solution!
     
  12. leecomo macrumors newbie

    Joined:
    Sep 1, 2010
    #12
    Samsung ML-2010 Problem with Mac OS10.5

    I tried what was suggested above, but no success. Same result :"No pages found" and job changes to "stopped"

    Does any one have another suggestion? Samsung does not know what to do.

    I am ready to "dump" this printer.
     
  13. powersmp macrumors newbie

    Joined:
    May 19, 2010
    #13
    Worked for me as well! It should be noted that I first installed the ML-2010 driver using "Samsung SPL2 Installer.app" which I was able to find on the Sumsung website http://www.samsung.com/us/support/downloads

    Once this was installed and I tried to print, it would just display "stopped" in the Samsung ML-2010 window. When I clicked info->driver i was able to change to ML-1630 Series and it immediately printed.

    I'm not sure if the installer app was necessary, or if you can immediately install the printer by going to system preferences->print&fax->and then telling it manually to use the ML-1630 driver(I can't check if that series is in by default since I used the app first throuh when I didn't see ML-2010). I am running OSX 10.5.8 on a MBP
     
  14. kocoman macrumors regular

    Joined:
    Dec 26, 2007
    #14
    I have the problem where the printer (ML-2010 receives the data (slow green led flash, but does not print it. (no fast green led flash). The Logs/queue does not show any error. I always have to turn off and on again the printer to fix it

    I used the latest 2.1 drivers from apple update, the model ML-1640 from the list as suggested
     
  15. sneakyimp macrumors newbie

    Joined:
    Feb 3, 2011
    #15
    I managed to get my ML-2010 printing using this kludge when the printer was connected directly to my MAC, however it doesn't help when I have my printer connected to a router.

    I need to add the printer as an IP printer and cannot get it to work.

    Any advice would be much appreciated.
     
  16. veronykah macrumors newbie

    Joined:
    Mar 15, 2010
    #16

Share This Page