Problem Printing to Shared Windows Printer

Discussion in 'Mac Basics and Help' started by tmoney468, Jan 27, 2008.

  1. tmoney468 macrumors 6502

    Joined:
    Mar 13, 2007
    #1
    Hi everyone, I've search on the forums here and I've tried several solutions but to no avail. Basically the problem is that I can't print to a shared Windows printer on my home network. I have no problem finding and printing to the printer on my other Windows PCs, but I've had no luck with either of my Macs.

    The printer is an Epson 2200. I've tried the following solution and I've only been able to get it working on my MBP, not my new Macbook (I set it up exactly the same but everytime I try to print it just freezes the app trying to print):

    I've also tried setting it up through CUPS, but I've only been able to get to the end where it asks for a user name and password and I can't figure out what the correct usage is (I'm assuming its the login and pass for the Windows machine? My macbook doesn't have a password on the account).

    Is there an easier solution to get this working? Sadly this is one thing about Macs that is less than "simple" for me as compared to PCs. Thanks!
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    When setting up in CUPS it's asking for an administrator username and password for the Macbook, not the Windows machine login. I can assure you that a Macbook running OS X does indeed have a password. You may not have to enter it on boot, but it's needed for any administrative tasks (like adding a printer in CUPS or even installing applications). You can't set up a user account without a password in OS X like you can in Windows.
     
  3. tmoney468 thread starter macrumors 6502

    Joined:
    Mar 13, 2007
    #3
    You are right, but I definitely didn't set up a password when I first configured the Macbook when I bought it. When I install anything it gives me the user name/password dialog box, and I've been able to leave the password field blank because I never gave the account a password. Is it possible that an admin account is required to set up CUPS? I would really like not to have to set up this account to have a password as that would irritate my mom more than anything.
     

Share This Page