Problem re-installing bootcamp drivers

Discussion in 'Windows, Linux & Others on the Mac' started by Hutchy, Aug 11, 2008.

  1. Hutchy macrumors member

    Joined:
    Apr 13, 2007
    #1
    Hi,

    I had a fully working Bootcamp XP partition on my system, and then I went and messed it all up by installing the Bootcamp 2.1 upgrade.

    The installation went with out a hitch but the keyboard drivers failed to load causing the volume buttons not to work.

    I decided to remove 2.1 and re-install 2.0.

    Now, i cannot install either of them. Its like only half of the drivers have been removed but the 'BootCamp' in 'Add/Remove Programs' has gone meaning I cannot remove anything else.

    When I try to install 2.0 I get the error "The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2753."

    I am installing straight from my Leopard disk and it has worked fine before. 2.1 does not even seem to load.

    Any help would be appreciated, thanks.
     
  2. Hutchy thread starter macrumors member

    Joined:
    Apr 13, 2007
    #2
    Hi not sure whether anybody is following this thread but to anybody who has had this error, try and get your hands on bootcamp installer 2.01. It seemed to cure my problem. I removed everything I could using Add/Remove Programs and ran the Bootcamp installer from a download. I was then able to upgrade it to 2.1.

    I hope this helps.

    (I had installer 2.0 off my leopard disk)
     
  3. McMenace macrumors newbie

    Joined:
    Aug 15, 2008
    #3
    Thanks for sharing... I'm having the same problem... I'll look for a download. A link would be great if you've got it.
     
  4. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #4
  5. Hutchy thread starter macrumors member

    Joined:
    Apr 13, 2007
    #5
    I think I used

    http://www.fulldls.com/torrent-others-828390.html

    which points towards Mac Pro drivers.

    I used the installer which was in the apple folder. I didn't use the default installer that runs automatically.

    Please tell me if this helps and if it is the right one.

    Eve though it is Mac Pro drivers, it worked on my iMac. I think within the Apple folder are just general Apple drivers.
     
  6. McMenace macrumors newbie

    Joined:
    Aug 15, 2008
    #6
    Hmm... this is where I show myself up as a real newbie to this sort of stuff...

    I've just bought a new iMac 24" 2.8 gb, and I'm trying to use the bootcamp drivers on a CD I used before, but probably with an early version of leopard (in fact I installed it from the same CD), so I assume my issue is compatibility with the newer version of leopard pre-installed on the iMac, and my older boot camp drivers (2.0) on the leopard CD.


    I thought 'download this torrent' would pull the lot, but the file size is only 44.6k. Did you have to download all the files individually?

    I'm also struggling to understand what you mean by your comment on which installer you used... sorry.
     
  7. McMenace macrumors newbie

    Joined:
    Aug 15, 2008
    #7
    I just realised I might have done something very dumb... now trying the drivers on the CD that came with the machine....durrr!

    If that doesn't work... I'll be back!
     

Share This Page