Problem recognising 3TB drives - possible work around

Discussion in 'Mac Accessories' started by Miat, Jul 10, 2013.

  1. Miat, Jul 10, 2013
    Last edited: Jul 10, 2013

    Miat macrumors 6502

    Joined:
    Jul 13, 2012
    #1
    I bought a couple of Western Digital 3TB Green drives (WD30EZRX) a while back for backup/archive storage, but couldn't get them to work properly in a Stardom SOHOTANK ST5610-4S-SB3 external enclosure (with USB 3 & eSATA connections, and 3 TB drive compatible). Smaller drives (500 GB, 1 TB, and 2 TB) of various brands (WD, Seagate, Hitachi) work fine in it.

    Was getting the previously reported issue of only 801 GB showing up on a 3 TB drive, plus serious problems with lost data; incomplete dismounting of the drives in the enclosure, mainly the 3 TB ones, but the others also had problems sometimes; and communication between the USB 2 iMac and the USB 3 enclosure was dodgy.

    Disk Utility showed the drive itself as 3 TB, but the volume on it as only 801 GB.

    I am running a 2012 Air, and a 2007 24" iMac, into the USB 3 port on the Stardom enclosure. Both have the same problems, (except for the extra comms problem with the iMac).

    :confused:

    Couldn't find a solution online. Nothing worked. Until...

    Out of sheer desperation I tried increasing the number of partitions (of equal size) on the 3 TB to see what happened, and at 5 partitions (600 GB size each) all the problems just completely disappeared. Since then I have run the drives up about 5-6 times a month with the iMac, and maybe 15 times with the Air, and it all seems to work fine.

    Not an ideal solution, but it is an okay work around for now, and is easy to do. At least I have my full 3TB of space back, and it works reliably.

    Would appreciate any feedback on this from anybody else who tries it.

    •••••

    I have just ordered a couple of 3TB Seagates (ST3000DM001), so it will be interesting to see if they have the same problem. Will update on that in 2-3 weeks.
     
  2. alkalifly macrumors regular

    alkalifly

    Joined:
    Apr 13, 2004
    #2
    Are you sure you are running the most up-to-date firmware on the enclosure?
     
  3. Miat thread starter macrumors 6502

    Joined:
    Jul 13, 2012
    #3
    No. Have not checked since I got the partitions working.

    Just checked and there was a recent firmware update on 18 June 2013. Now to find to find a Windows machine to install it.

    Update here: http://www.stardom.com.tw/sohotank_spec.html

    Thanks for the reminder. :)
     
  4. alkalifly macrumors regular

    alkalifly

    Joined:
    Apr 13, 2004
    #4
    Yeah, I had the same issue with an enclosure a while ago, it wouldn't play nice with any drive >2GB until the firmware was updated, then worked perfectly afterward. FWIW, I was able to do the firmware update using a windows virtual machine
     

Share This Page