Problem reformatting WD 750GB My Book Essential

Discussion in 'Mac Accessories' started by jtbell, Mar 19, 2009.

  1. jtbell macrumors newbie

    Aug 2, 2008
    South Carolina, USA
    Today I bought a new external HD (Western Digital 750GB My Book Essential) for archiving my burgeoning collection of video files. I figured the first thing I needed to do was to reformat it, because I remembered that the default PC FAT32 file system can't handle large files, tens of GB, like I get from recording long TV programs in EyeTV.

    So I went into Disk Utility, selected "Erase," chose "Mac OS Extended (Journaled)" and got a format error! "Oh jeez, do I have to take this sucker back to Best Buy and exchange it?"

    Then I tried partitioning it into two equal partitions, and it worked! Then I tried to re-format back to one partition, and it failed again. "That's odd, I don't remember there being a partition size limit."

    So I Googled for something like "Mac OS X volume size limit" and turned up an Apple support page which confirmed that I should not be having a problem with the size of that volume under OS X 10.5.

    Finally, I came here, and after some browsing and searching, turned up
    this thread which has the solution in post #3.

    Therefore, I no longer have a problem, but since the solution was not obvious to me at first, and a lot of other people are probably having similar problems with reformatting large disks, I thought it would be worth providing some more fodder for the search engines to help people find the solution.

    And thanks to 'sicmacdoc' for providing it...

Share This Page