Problem regarding icons.

Discussion in 'Mac Basics and Help' started by palsi, Sep 7, 2010.

  1. palsi macrumors newbie

    Joined:
    Sep 7, 2010
    #1
    First post, so I'm sorry if I break etiquette.

    I'm having a problem regarding icons. I don't know what happened to cause it, but my icons for specific file types have disappeared. For instance, all images have no icon but still have the file name. When previewed, the image shows up. Also, some of my images are displaying that they are to be opened with Safari, which makes no sense, and none of them are opening up. Another problem is that all folder icons have disappeared, but I am still able to access the folders. The MobileMe iDisk icon has also disappeared from my finder window, and on the desktop has reverted to a generic disk image. I cannot click on the icon to click or drag but have to click on the file name to do anything involving click and drag or right click. I've also noticed that clicking on a file type like a .docx file if the icon is missing will reveal the icon.

    I've included some screenshots of what I'm experiencing, and I'm running 10.6.4 at 2.53GHz Intel Core 2 Duo, 4GB 1067 Mhz DDR3 on a MacbookPro 5,4

    I've cleared my plist, repaired disk permissions via Disk Utility and Onyx, and have restarted to no avail.

    If I forgot to say something important to the fix please let me know! I also am kind of scared that this is indicative to a greater problem! Any help is greatly appreciated, and if nothing works I plan on archiving and reinstalling!

    I'm seriously extremely grateful for any and all help guys!

    [​IMG]
    [​IMG]
    [​IMG]
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    You've "cleared" which plist file?

    Have you looked in Show View Options? There is a checkbox for showing icon previews. Reverse it (with one click) and see if that helps. If it does, then go back and click on Use as Defaults to apply the change to all windows.
     
  3. palsi thread starter macrumors newbie

    Joined:
    Sep 7, 2010
    #3
    com.apple.finder.plist is what I cleared. I saw that some people had this problem as well and that seemed to fix it for some, but not for me.

    I just did that to no avail. Doesn't seem to help, changing the size of the icon did not help either.

    I appreciate the response greatly, any other ideas maybe?
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    In other words, if it's checked, uncheck it. If it's unchecked, check it. My suggestion has nothing to do with changing the icon size.
     

Share This Page