Problem Right Clicking

Discussion in 'macOS' started by Vtorch, Apr 23, 2007.

  1. Vtorch macrumors member

    Joined:
    Oct 31, 2006
    #1
    Hello,

    Everytime I right click with the mighty mouse on the desktop or press Command and Click on my Powerbook I no longer am able to get a menu to which I can create a new folder or "Get info" on a particular file. As a matter of fact, when I do right click, the icons on my desktop disappear for (about) 2 seconds and then reappear again.

    I have been playing around with a few file compressions programs such as Yemuzip and JIMzip. This strange behavior seemed to have started once I tried to move over some zip files to an external hard drive. Other than that, I have no clue what may or may not have caused this really strange computer behavior.

    Anyone have any ideas what happened and what I can do to fix this?
     
  2. AutumnSkyline macrumors regular

    AutumnSkyline

    Joined:
    Oct 5, 2006
    #2
    Do you have right click set up right on your might mouse for context menus (go to apple>system prefs>keyboard&mouse
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    If the desktop files are disappearing and momentarily re-appearing, and particularly if the dock disappears and then comes back a few seconds later, this is an indication that Finder is crashing and restarting itself -- if you've ever used Windows and been told that Explorer had an error and was shutting down, and the start bar went away and then came back, essentially the same thing.

    Sometimes it is due to corrupt files that are used to manage external drives -- it could be a .ds_store file on your external drive that was updated while copying the zip files.

    Could also be the finder plist file.
     
  4. Vtorch thread starter macrumors member

    Joined:
    Oct 31, 2006
    #4
    mkrishnan, the information you gave me was very helpful. it gave me a starting point to which i was able to find the solution. One of those file compression programs, JIMZIP, put a plugin in the Contextual Menu Folder to which I just deleted it. Once I deleted it, everything went back to normal. Thank you.

    Autumnskyline, Thanks for responding.
     
  5. duffsrp macrumors member

    Joined:
    Oct 29, 2004
    Location:
    Carlsbad
    #5
    I'm having the same issue. But I have no idea when it started. I too use external drives and .zip files. Where do I need to look for the corrupted file or files? This just bugs. I want the use of my right click back.
     
  6. djejrejk macrumors 6502a

    djejrejk

    Joined:
    Jan 3, 2007
    Location:
    Uhh...
    #6
    Check out this thread

    http://forums.macrumors.com/showthread.php?t=301941

    and this one that I just posted this morning

    http://forums.macrumors.com/showthread.php?t=302695

    I had the same problem,.. to shorten the story, stuffit was causing the problem. I deleted the stuffit plugin file from library> Contextual Menu Items and now finder does not crash.

    nevermind.. looks like you already fixed it..
     
  7. duffsrp macrumors member

    Joined:
    Oct 29, 2004
    Location:
    Carlsbad
    #7
    Thanks for the help. I'm DL'ing the stuffit update. I'll see if that fixes it. They say it should on their update site. If not I'll delete the plugin in my contextual menu folder.
     

Share This Page