Problem scrolling magic mouse 2 with egpu connected

Discussion in 'Windows, Linux & Others on the Mac' started by cuppino, Apr 24, 2019.

  1. cuppino, Apr 24, 2019
    Last edited: Apr 24, 2019

    cuppino macrumors member

    Joined:
    Nov 14, 2018
    #1
    Hello everyone,
    Scrolling (I mean the mouse wheel function) of the magic mouse 2 does not work when I connect the egpu in windows 10.
    If I restart in windows without egpu everything works properly, but as soon as I connect the egpu the scrolling doesn't work anymore.
    I have already formatted many times without a positive result.
    What do you think I can do to resolve?
    I tried this little program https://magicutilities.net/ and it manages to solve my problem, but it's paid (it's a subscription) and I don't like it as an idea.
    I use the mac in signature.
     
  2. Chocomonsters, Apr 27, 2019
    Last edited: Apr 27, 2019

    Chocomonsters macrumors regular

    Joined:
    May 22, 2007
    #2
    Does other USB device or bluetooth device work?

    You may have resource problem. Can you check under "device manager" to see if you still have enough resources available with eGPU? Also don't use USB-C port on RTX 2070. If you don't use it, you can safely disable it along with nvidia high def audio controller to free up more resources. You can safely disable HD audio for Radeon or any PCIe controller you dont use.


    [​IMG]
     

    Attached Files:

  3. cuppino thread starter macrumors member

    Joined:
    Nov 14, 2018
    #3
    Thank you for your reply!
    I checked and it doesn't seem to have resource problems. I have no error triangles anywhere.
    When I turn on the egpu (now I've changed it with a rtx 2080 ti) for a few seconds it turns off and reactivates the bluetooth on its own and from that moment mouse scrolling ("center wheel" does not work, but the mouse for the rest works , the arrow moves, the keys click and issue commands.
    I believe that for some reason when you turn off the bluetooth for the egpu the mouse driver is not reloaded correctly.
    The small program in fact does nothing but re-run the mouse and then it works again. Without deactivating any pcie resources.
     
  4. Chocomonsters macrumors regular

    Joined:
    May 22, 2007
    #4
    Do you boot your iMac with Razor Core X on or hot plug? It sounds like you are turning on your Razor Core X after boot. If you are turning on eGPU after boot or hot plugging it after boot, you may still have resource issue.

    Can you disable unused PCIe including all NVIDIA audio and try boot with with eGPU? You are running Radeon on your PCIe x16 controller and likely running eGPU on either x4 or x8 controller. Can you try to run your external SSD and other peripherals on non-eGPU PCIe controller?

    I have 2018 MacBook Pro 15 (i9-8950HK) with Windows 10 running on external Akitio TB3 NVMe, Elgato TB3 dock, Ankitio eGPU with RTX 2080. As you can see, Radeon is on x16 controller, eGPU with RTX 2080 on x4 controller, and external TB3/SSD, TB3 dock, and all USB peripherals (blu ray drive, external SSD time machine, scanner, USB DAC-amp, and etc) on x8 controller. If I don't disable some PCIe or Nvidia audio stuff, Windows 10 will occasionally rearrange resources when I plug in other USB devices (ie, iPhone and etc.). This will mess up random things until I reboot.

    Unfortunately you and I have two heavy resource hogs (two video cards) and Windows can struggle with resources even with a large memory space enabled on recent Mac's firmware.
     
  5. cuppino thread starter macrumors member

    Joined:
    Nov 14, 2018
    #5
    I created to test a bootcamp partition on internal ssd and to connect the egpu, but I always have the same anomaly with the mouse.
    I tried to disable all the resources as in your image but it didn't help.
    I connect the egpu to the login screen or when I'm at the desktop.
    If I turn it on first, the Mac remains locked on a black screen.
    When I start windows from external ssd it is connected to a usb 3.0 port of the mac.
    I have only one nuisance with the central mouse wheel function.
    For the rest, everything works normally and I can connect anything without problems with the connected egpu.
    If a simple software unlocks the "central wheel" I don't think it's a resource problem but a driver problem.
    Also because I have no error in the resource scheme even with everything active.
    I believe that at this point I have to consider whether to subscribe to the software or whether to buy a mouse only for windows or ignore the problem and not use the central wheel when I use the egpu.
     

Share This Page

4 April 24, 2019