Problem sending email when on wi-fi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rctoyguy, May 22, 2009.

  1. rctoyguy macrumors newbie

    Joined:
    Dec 31, 2008
    #1
    What settings need to be changed to send email when on wi-fi? I have cwmx as the outgoing server,but if I'm on wi-fi,i can't send mail - I'm guessing because cwmx will only pass email from it's ip address range.
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    Is this a personal e-mail using a custom URL?

    Because of ISP restictions on e-mail I had to set my personal e-mail on my iPhone up differently for home-wifi than for AT&T 3G.

    In other words, I had to chose which one I wanted to work and which one to not work! I set it to work with 3G and just turned wifi off when I wanted to check e-mail. Major pain.

    I eventually gave up and switched to gmail. My ISP knows what gmail is and allows it to work without the special settings other e-mail services are required to have, so now I can get and send e-mail no matter what network I'm on.

    So, bottom line: I never got my own e-mail to work. After 3 months of trying I gave up and used gmail instead.

    Sorry :(
     
  3. rctoyguy thread starter macrumors newbie

    Joined:
    Dec 31, 2008
    #3
    I actually have 2 outgoing servers configured.

    cwmx.com for 3g times, and mail.charter.net (my home isp) for when I'm on home wi-fi.

    When on wi-fi, it *might* send, but it can take a very long time. I'm guessing it has to fail out of trying the cwmx.com before it rolls over to try the other one.

    I hoped there was a better way of setting this up so that it always works - I don't know how it would react if I'm on a wi-fi network other than at home.

    I have thought about the gmail solution, but haven't tried it yet.
     
  4. Ntombi macrumors 68030

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #4
    Charter won't let you to send from other than your own IP, so I have my first choice as charter, and then the AT&T server. But I had the same long send times as you on my home wifi. It was fixed when I reset my router and modem. Now it sends within two or three seconds. Cwmx still takes a good minute, though.
     

Share This Page