Problem setting the hdtv to the correct resolution when connected to my macbook pro

Discussion in 'MacBook Pro' started by Bathplug, Aug 5, 2011.

  1. Bathplug macrumors 6502a

    Joined:
    Jul 12, 2010
    #1
    I have a 2011 15" macbook pro & mini display port to hdmi adapter. When I set it up to my samsung hdtv the text and overall picture quality isn't very clear on the tv.

    I also have my pc connected to the tv using a vga cable and it looks fine, in the display properties on the pc it's set to 1360x768.

    The resolutions settings I have for the samsung tv in preference on the mac are 1080i, 720p, 480p etc and all look crap to me. If I set my hdtv to the 720p option in preferences then press the info button on the tvs remote it says 1280x720p. How do I get it to 1360x768? Should I have gotten a via adapter for my mac book pro instead?

    The tv is old and here are the specs.

    26" samsung hdtv http://www.play.com/Electronics/Elec...V/Product.html

    Resolution: 1366x768
    Brightness: 500 cd/2
    Dynamic Contrast: Yes (3000:1)
    Response Time: 8ms

    Thanks
    Bathplug is online now Report Post
     
  2. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    You can try SwitchResX to force the proper resolution.

    Hopefully that will work, but there are many possible problems.
     
  3. Bathplug, Aug 5, 2011
    Last edited: Aug 5, 2011

    Bathplug thread starter macrumors 6502a

    Joined:
    Jul 12, 2010
    #3

    I'm trying that now but haven't got a clue how to use it. It says the default resolution for the samsung tv is 1280x720 which I can change but nothing happens. Edit: I manage to figure it out but my tv says display not supported.

    Will the tv just work if I get a vga adapter instead? Why isn't there an option for the resolution I want anyway, do all hdtvs have this problem? I looked on youtube and most people just plug in there hdtv and they work fine, do I need a full 1080p tv for this to work without the hassle?

    Thanks
     

Share This Page