Problem Switching between Ethernet and Wifi

Discussion in 'MacBook Pro' started by abeckman702, Nov 7, 2012.

  1. abeckman702 macrumors newbie

    Joined:
    Nov 7, 2012
    #1
    When I am connected to Wifi everything works great, however when I want to switch to ethernet, I turn off Airport and connect the network cable. The symbol for ethernet stays red and only turns yellow then green to obtain an IP via DHCP after putting the system to sleep and waking it back up. After it obtains and IP, it works perfect on ethernet. Has anyone else experienced the same thing? Any help would be greatly appreciated!
     
  2. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #2
    So if works. You are saying it bothers you that it's not more convenient?

    Try this: Don't do anything to airport. (1)Turn Off WIFI at the MBP. (2)THEN plug the ethernet cable, give it a few seconds between actions, don't be impatience.
     
  3. stevelam macrumors 65816

    Joined:
    Nov 4, 2010
    #3
    no. hes saying it DOESNT work until he has to put the mbp to sleep and wake it up.
     
  4. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #4
    I think there's a setting to set ethernet first in the order of using networks.

    I use wifi in my living room, and then simply close the lid and go to the other room with ethernet and plug that in when I want to use the faster connection. There's no need to turn off airport or wifi.
     
  5. abeckman702 thread starter macrumors newbie

    Joined:
    Nov 7, 2012
    #5
    Exactly! If I don't turn airport off before connecting to the ethernet it seems to work ok.
     

Share This Page