Problem syncing JB iPhone - apps are blocked and I cannot sync

Discussion in 'Jailbreaks and iOS Hacks' started by maopequena, May 27, 2010.

  1. maopequena macrumors newbie

    Joined:
    May 27, 2010
    #1
    Hi, I've JB my iPhone (OS 3.1.2, redsnow 0.9.2). After the JB, I synced many apps from the appstore. Now I've bought some other apps and when I tried to connect my iPhone to sync them, the apps were there, but I wasn't able to sync them. The box to sync automatically is checked, but the entire apps area is a light grey (as if it is disabled).
    I also tried dragging the apps directly to the iPhone icon in iTunes, but that doesn't seem to get me anywhere either.
    I'm syncing my iPhone from Brazil, and this is my appstore, but I don't think this matters (or does it?).
    The apps I had already synced work just fine, the phone works fine. I can still add music and videos to the iPhone, but not apps.
    Can anyone help me? :confused:
    Thx
     
  2. Dan14 macrumors regular

    Joined:
    Aug 28, 2009
    #2
    Try unticking the box next to "sync apps" so it removes all ticks from every app. Then sync so it removes all your apps and then tick it and sync again.

    Failing that, you may be looking at a restore?
     
  3. maopequena thread starter macrumors newbie

    Joined:
    May 27, 2010
    #3
    Thanks for the timely response, Dan14.

    I saw that solution online already, but the problem is that I can't untick the box (because it's in light gray, disabled).
    I also already restored the phone, and it didn't work also. The restore maintains all the apps I had already synced, but doesn't help with syncing the new ones (apps area remains light gray).

    Do you think there is any other possibility? Does anyone? Or every time I want to sync my apps I'll have to reinstall the OS all over, from scratch? Because the first time it happened, I thought it might be a installation problem and reinstalled the OS, JBd it and synced. Now, when I tried to sync it again and it didn't work I noticed it's not an installation problem.

    I've already searched so many forums, and I'm almost losing hope here. :(
     

Share This Page