Problem: trackpad Tap-to-click stops working intermittently

Discussion in 'MacBook Pro' started by babucher, Dec 17, 2010.

  1. babucher macrumors newbie

    Joined:
    Apr 28, 2005
    #1
    Macbook Pro 4,1 (15inch)
    OSX 10.5.8

    I posted a reply on the only relevant thread I found, and just now realized it was in the Macbook forum, not the Macbook Pro, which I have. So, I'm reposting here. I'd appreciate any suggestions.

    I'm having a problem with the trackpad. It loses the ability to tap-to-click even though the box is still checked in the Trackpad system preferences. To get it working again I have to open system preferences, uncheck tap-to-click to 'officially' disable it, and then check it again to enable it. This is quite annoying, as it's happening frequently now. Multiple times an hour. It's been going on for at least several weeks.

    I should note that what sometimes happens between "Tap to click working" and "Tap to click not working" is that my system goes into a key-repeat mode. That is, for example, I'll be typing and my s key will start repeating until I hit esssssssssssssssssscape. Like that. Then, Tap-to-click no longer works and I have to do the uncheck/check procedure.

    Any thoughts? Thanks
     
  2. BittenApple macrumors 6502a

    BittenApple

    Joined:
    Nov 29, 2008
    #2
    Have you tried creating a new account and logging into it and testing if you have the same problem in this new account?
     
  3. babucher thread starter macrumors newbie

    Joined:
    Apr 28, 2005
    #3
    Based on your suggestion (thank you, by the way), I created a new account and tested it. Unfortunately the problem occurs on the new account as well. Is there any way to track the Trackpad signal? I'm thinking perhaps there's a Developers tool that can be used for debugging the trackpad io.

    Thanks
     
  4. wanders macrumors newbie

    Joined:
    Mar 22, 2011
    #4
    Same thing here!

    I hate to bump an old thread like this, but I've been searching everywhere for some information on this issue.

    I too have a MacBook Pro 4,1 and BootCamp produces precisely the problem OP is talking about -- after a while, inevitably, my trackpad stops working properly. The mouse tracking speed seems to go way down, and tap-to-click / two-finger scroll / two-finger secondary click all stop working. Attempting to scroll with two fingers just moves the mouse cursor.

    What's more, if I'm typing when this problem spontaneously happens, I get the same keyboard "freeze" where the key I was typing repeats itself several times. Believe it or not, it just happened again while I was typing "freeze."

    My problem differs in that going to the Boot Camp control panel and un-checking / re-checking everything doesn't do anything. The problem only resolves itself when I put the computer to sleep and wake it back up. Even then, the problem seems to snowball and occur more often once it gets going.

    I've tried uninstalling and reinstalling boot camp, the specific HID drivers, and reinstalling Windows -- all to no avail. Because OP has the same revision MBP, and I haven't heard any other complaints like this anywhere else, I'm suspicious that this issue is specific to the 4,1 MBP. Because it's three years old, that would seem to leave us high and dry because few others will have this problem. It's almost as if Apple is trying to sabotage my Windows experience.
     

Share This Page